aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rocksndiamonds
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rocksndiamonds
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rocksndiamonds')
-rw-r--r--recipes/rocksndiamonds/files/rocksndiamonds.pngbin0 -> 1114 bytes
-rw-r--r--recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb27
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes/rocksndiamonds/files/rocksndiamonds.png b/recipes/rocksndiamonds/files/rocksndiamonds.png
new file mode 100644
index 0000000000..a93d6d4e73
--- /dev/null
+++ b/recipes/rocksndiamonds/files/rocksndiamonds.png
Binary files differ
diff --git a/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb b/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb
new file mode 100644
index 0000000000..3932bd5f98
--- /dev/null
+++ b/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Rocks'n'Diamonds - Boulderdash/Emerald Mine/Supaplex/Sokoban clone."
+SECTION = "games"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.artsoft.org/rocksndiamonds/"
+AUTHOR = "Holger Schemel <info@artsoft.org>"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://artsoft.org/RELEASES/unix/rocksndiamonds/rocksndiamonds-${PV}.tar.gz \
+ file://rocksndiamonds.png"
+
+DEPENDS += "libsdl-net smpeg"
+
+APPIMAGE = "../rocksndiamonds.png"
+EXTRA_OEMAKE = "CC='${CC}' AR='${AR}' RANLIB='${RANLIB}' RO_GAME_DIR='${datadir}/${PN}' RW_GAME_DIR='${datadir}/${PN}'"
+
+inherit sdl
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${PN} ${D}${bindir}
+ install -d ${D}${datadir}/${PN}
+ cp -r graphics levels music scores sounds ${D}${datadir}/${PN}/
+}
+
+
+FILES_${PN} += "${bindir}/${PN} ${datadir}/${PN}"