summaryrefslogtreecommitdiffstats
path: root/recipes/rott/rott_1.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rott/rott_1.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rott/rott_1.0.bb')
-rw-r--r--recipes/rott/rott_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/rott/rott_1.0.bb b/recipes/rott/rott_1.0.bb
new file mode 100644
index 0000000000..e1fc4e6a74
--- /dev/null
+++ b/recipes/rott/rott_1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Rise of the Triad - an SDL based Doom clone - QtE based Palmtop Environments Edition"
+HOMEPAGE = "http://www.icculus.org/root"
+LICENSE = "GPL"
+PR = "r2"
+
+APPIMAGE = "${WORKDIR}/rott.jpg"
+
+SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz \
+ file://gcc4.patch;patch=1;pnum=2 \
+ file://rott.jpg"
+S = "${WORKDIR}/rott-${PV}/rott"
+
+CFLAGS += "-DPLATFORM_UNIX"
+EXTRA_OEMAKE = 'SDL_INC_DIR=${STAGING_INCDIR}/SDL CC="${CC}" EXTRALDFLAGS="${LDFLAGS}"'
+
+inherit sdl
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 rott ${D}${bindir}
+}