aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rox
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rox
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rox')
-rw-r--r--recipes/rox/files/no-strip-objcopy.patch13
-rw-r--r--recipes/rox/rox-filer_2.5.bb56
2 files changed, 69 insertions, 0 deletions
diff --git a/recipes/rox/files/no-strip-objcopy.patch b/recipes/rox/files/no-strip-objcopy.patch
new file mode 100644
index 0000000000..181dccc436
--- /dev/null
+++ b/recipes/rox/files/no-strip-objcopy.patch
@@ -0,0 +1,13 @@
+--- /tmp/Makefile.in 2006-09-04 22:08:51.000000000 +0200
++++ rox-filer-2.5/ROX-Filer/src/Makefile.in 2006-09-04 22:09:00.275780000 +0200
+@@ -51,10 +51,6 @@
+ ${PROG}: ${OBJECTS}
+ ${CC} -o "${PROG}" ${OBJECTS} ${LDFLAGS}
+ mv "${PROG}" "${PLATFORM_DIR}"
+- -(cd "${PLATFORM_DIR}" && \
+- objcopy --only-keep-debug ROX-Filer ROX-Filer.dbg && \
+- strip ROX-Filer && \
+- objcopy --add-gnu-debuglink=ROX-Filer.dbg ROX-Filer)
+
+ clean:
+ rm -f *.o Makefile.bak
diff --git a/recipes/rox/rox-filer_2.5.bb b/recipes/rox/rox-filer_2.5.bb
new file mode 100644
index 0000000000..767e42b04d
--- /dev/null
+++ b/recipes/rox/rox-filer_2.5.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "File manager at the core of the ROX desktop"
+HOMEPAGE = "http://rox.sf.net"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS = "gtk+ shared-mime-info"
+RDEPENDS = "shared-mime-info"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/rox/${P}.tar.bz2 \
+ file://no-strip-objcopy.patch;patch=1;pnum=3"
+
+inherit mime pkgconfig
+
+S = "${WORKDIR}/${P}/ROX-Filer/src/"
+
+do_compile() {
+ ../AppRun --compile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ../ROX-Filer ${D}${bindir}
+
+ install -d ${D}${datadir}/rox/Choices
+ install -d ${D}${datadir}/rox/images
+ install -d ${D}${datadir}/mime/packages
+ install -d ${D}${datadir}/doc/rox/html
+ install -d ${D}${mandir}/man1
+
+ gzip -c9 ${WORKDIR}/${P}/rox.1 >${D}${mandir}/man1/rox.1.gz
+
+ cp -r ${WORKDIR}/${P}/Choices ${D}${datadir}/rox
+ rm -rf ${D}${datadir}rox/Choices/MIME-info/
+ cp ${WORKDIR}/${P}/ROX-Filer/*.xml ${D}${datadir}/rox
+
+ cp ${WORKDIR}/${P}/ROX-Filer/Help/{Changes,README*,TODO} ${D}${datadir}/doc/rox
+ cp ${WORKDIR}/${P}/ROX-Filer/Help/*html ${D}${datadir}/doc/rox/html
+ cp ${WORKDIR}/${P}/ROX-Filer/style.css ${D}${datadir}/doc/rox/html
+ cp -r ${WORKDIR}/${P}/ROX-Filer/images ${D}${datadir}/rox
+ cp -r ${WORKDIR}/${P}/ROX-Filer/ROX ${D}${datadir}/rox
+
+# cp ROX-Filer/ROX-Filer ${D}/usr/bin/rox
+ cp ${WORKDIR}/${P}/ROX-Filer/.DirIcon ${D}${datadir}/rox/.DirIcon
+ cp ${WORKDIR}/${P}/rox.xml ${D}${datadir}/mime/packages
+
+ for f in ${WORKDIR}/${P}/ROX-Filer/Messages/*.gmo; do
+ export ROXTMP=`basename $f .gmo` ;
+ if [ $ROXTMP == "sp" ]; then
+ export ROXTMP="es" ;
+ fi
+ install -d ${D}${datadir}/locale/$ROXTMP/LC_MESSAGES;
+ cp $f ${D}${datadir}/locale/$ROXTMP/LC_MESSAGES/rox.mo;
+ done
+}
+
+FILES_${PN} += "${datadir}/rox/ ${datadir}/mime/packages"