summaryrefslogtreecommitdiffstats
path: root/recipes/rpm/rpm-native_4.4.2.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-24 14:01:30 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-24 14:01:30 -0700
commit0faff8720150863ff38132f87ef65721fcb86dc1 (patch)
tree476c4a2a832da00b87aed99f8c0d4d72c845efcd /recipes/rpm/rpm-native_4.4.2.3.bb
parentaf33616e7ede94c06a866ef7e886e65426b088ec (diff)
downloadopenembedded-0faff8720150863ff38132f87ef65721fcb86dc1.tar.gz
distutils-base.bbclass: Move common functionality to distutils-common-base.bbclass
Create a new class distutils-common-base.bbclass which holds the common parts that can be used in native and target packages which need to use distutils funtionality. rpm, libxml2, zope are currently using them and needed to use distutils-native-base for native recipes. rpm and libxml need to defer the processing of certain configure parameters which we evaluate using python. So we need to have python-native built before we can process them. Hence we can not use EXTRA_OECONF which is a python variable and gets expanded during parsing recipes and ofcourse we have not yet built python-native. We pass these extra options as a separate shell variable to do_configure which we evaluate when that task is executing.
Diffstat (limited to 'recipes/rpm/rpm-native_4.4.2.3.bb')
-rw-r--r--recipes/rpm/rpm-native_4.4.2.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/rpm/rpm-native_4.4.2.3.bb b/recipes/rpm/rpm-native_4.4.2.3.bb
index 935d07723f..287383c8c9 100644
--- a/recipes/rpm/rpm-native_4.4.2.3.bb
+++ b/recipes/rpm/rpm-native_4.4.2.3.bb
@@ -1,5 +1,6 @@
-require rpm_${PV}.bb
-inherit native
+inherit native distutils-native-base
+
+require rpm-${PV}.inc
DEPENDS = "beecrypt-native gettext-native zlib-native file-native popt-native python-native"