aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rt-tests
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2009-09-14 11:37:17 -0400
committerCliff Brake <cbrake@bec-systems.com>2009-09-14 11:37:44 -0400
commite00a889a30ca4756e4964261fa8ce36317efe481 (patch)
tree44a86b4745360f6250ba7681bcace04966aed557 /recipes/rt-tests
parent0e4c4a74ae68668ac7df3a3236248c0ceec5638a (diff)
downloadopenembedded-e00a889a30ca4756e4964261fa8ce36317efe481.tar.gz
rt-tests: add git recipe
Diffstat (limited to 'recipes/rt-tests')
-rw-r--r--recipes/rt-tests/rt-tests_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/rt-tests/rt-tests_git.bb b/recipes/rt-tests/rt-tests_git.bb
new file mode 100644
index 0000000000..fbb07911c6
--- /dev/null
+++ b/recipes/rt-tests/rt-tests_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Real-time tests, such as cyclictest, for real-time linux PREEMPT RT kernels"
+HOMEPAGE = "http://rt.wiki.kernel.org/index.php/Cyclictest"
+LICENSE = "GPL"
+PR = "r0"
+
+SRCREV = "42ab9e7cd259fae674dc2b2aa2962caaf8f09409"
+
+PV = "0.51+${PR}+gitr${SRCREV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tglx/rt-tests;protocol=git"
+
+S = "${WORKDIR}/git"
+
+# Limit to cyclictest only for non-real-time kernels.
+# EXTRA_OEMAKE = "cyclictest"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_install() {
+ install -d ${D}${bindir}
+ # any file that is executable by user and/or group
+ for binary in `find . -perm /u+x,g+x -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
+}