aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rt2x00
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-22 16:22:30 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:29 +0200
commitbb3c6f24758b490366543e7392dd13cdcb200b6f (patch)
tree682049818f80651900d07e7c4bf91037170d55fd /recipes/rt2x00
parent616f5f6d11a71401eb6dbd4585db972178b2b339 (diff)
downloadopenembedded-bb3c6f24758b490366543e7392dd13cdcb200b6f.tar.gz
rt3070: also install .bin file, move to directory with other ralink recipes
Diffstat (limited to 'recipes/rt2x00')
-rw-r--r--recipes/rt2x00/files/config.patch20
-rw-r--r--recipes/rt2x00/files/makefile.patch11
-rw-r--r--recipes/rt2x00/rt3070_2.1.1.0.bb29
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes/rt2x00/files/config.patch b/recipes/rt2x00/files/config.patch
new file mode 100644
index 0000000000..89a26caea0
--- /dev/null
+++ b/recipes/rt2x00/files/config.patch
@@ -0,0 +1,20 @@
+--- 2009_0525_RT3070_Linux_STA_v2.1.1.0/os/linux/config.mk 2009-05-20 20:33:56.000000000 -0700
++++ 2009_0525_RT3070_Linux_STA_v2.1.1.0/os/linux/config.mk 2009-08-22 19:42:55.000000000 -0700
+@@ -4,15 +4,11 @@
+ # Support 28xx QA ATE function
+ HAS_28xx_QA=n
+
+-#ifdef WPA_SUPPLICANT_SUPPORT
+ # Support Wpa_Supplicant
+-HAS_WPA_SUPPLICANT=n
+-#endif // WPA_SUPPLICANT_SUPPORT //
++HAS_WPA_SUPPLICANT=y
+
+-#ifdef NATIVE_WPA_SUPPLICANT_SUPPORT
+ # Support Native WpaSupplicant for Network Maganger
+-HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
+-#endif // NATIVE_WPA_SUPPLICANT_SUPPORT //
++HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
+
+ #Support Net interface block while Tx-Sw queue full
+ HAS_BLOCK_NET_IF=n
diff --git a/recipes/rt2x00/files/makefile.patch b/recipes/rt2x00/files/makefile.patch
new file mode 100644
index 0000000000..ca949023cf
--- /dev/null
+++ b/recipes/rt2x00/files/makefile.patch
@@ -0,0 +1,11 @@
+--- 2009_0525_RT3070_Linux_STA_v2.1.1.0/Makefile 2009-05-20 20:33:56.000000000 -0700
++++ 2009_0525_RT3070_Linux_STA_v2.1.1.0/Makefile 2009-06-23 19:57:21.000000000 -0700
+@@ -153,7 +153,7 @@
+ else
+ cp -f os/linux/Makefile.6 $(RT28xx_DIR)/os/linux/Makefile
+ make -C $(LINUX_SRC) SUBDIRS=$(RT28xx_DIR)/os/linux modules
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
++# cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
+ endif
+
+ clean:
diff --git a/recipes/rt2x00/rt3070_2.1.1.0.bb b/recipes/rt2x00/rt3070_2.1.1.0.bb
new file mode 100644
index 0000000000..324471ad8f
--- /dev/null
+++ b/recipes/rt2x00/rt3070_2.1.1.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Ralink 3070"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+PR = "r2"
+
+inherit module
+
+SRC_URI = "http://www.ralinktech.com.tw/data/drivers/2009_0525_RT3070_Linux_STA_v${PV}.tar.bz2 \
+ file://makefile.patch;patch=1 \
+ file://config.patch;patch=1 \
+ "
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/2009_0525_RT3070_Linux_STA_v${PV}"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -m 0644 ${S}/os/linux/rt3070sta.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -d ${D}/etc/Wireless/RT2870STA
+ install -m 0644 ${S}/RT2870STA.dat ${D}/etc/Wireless/RT2870STA
+ install -d ${D}/lib/firmware
+ install -m 0644 ${S}/common/*.bin ${D}/lib/firmware/
+}
+
+PACKAGES =+ "${PN}-firmware"
+FILES_${PN}-firmware = "/etc /lib/firmware"
+
+RDEPENDS_${PN} = "${PN}-firmware"