aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rt2x00
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2010-09-26 23:06:42 +0000
committerutx@penguin.cz <utx@penguin.cz>2010-09-26 23:06:42 +0000
commitf8ea4b433ddb01682b278279b8d2f9b86f97a308 (patch)
tree690784b92394fe5d66af550b6b86ef802db6d0b7 /recipes/rt2x00
parentd95fcc5d0c67c905924f909682aa7bbd770236a1 (diff)
downloadopenembedded-f8ea4b433ddb01682b278279b8d2f9b86f97a308.tar.gz
rt3070: Added version 2.3.0.4.
Diffstat (limited to 'recipes/rt2x00')
-rw-r--r--recipes/rt2x00/rt3070-2.3.0.4/makefile.patch13
-rw-r--r--recipes/rt2x00/rt3070_2.3.0.4.bb40
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes/rt2x00/rt3070-2.3.0.4/makefile.patch b/recipes/rt2x00/rt3070-2.3.0.4/makefile.patch
new file mode 100644
index 0000000000..a5256c7071
--- /dev/null
+++ b/recipes/rt2x00/rt3070-2.3.0.4/makefile.patch
@@ -0,0 +1,13 @@
+Index: DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/Makefile
+===================================================================
+--- DPO_RT3070_LinuxSTA_V2.3.0.4_20100604.orig/Makefile
++++ DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/Makefile
+@@ -304,7 +304,7 @@ ifeq ($(OSABL),YES)
+ cp -f $(RT28xx_DIR)/os/linux/rtnet$(CHIPSET)apsta.ko /tftpboot
+ endif
+ else
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
++# cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
+ ifeq ($(OSABL),YES)
+ cp -f $(RT28xx_DIR)/os/linux/rtutil$(CHIPSET)sta.ko /tftpboot
+ cp -f $(RT28xx_DIR)/os/linux/rtnet$(CHIPSET)sta.ko /tftpboot
diff --git a/recipes/rt2x00/rt3070_2.3.0.4.bb b/recipes/rt2x00/rt3070_2.3.0.4.bb
new file mode 100644
index 0000000000..c51cf7472f
--- /dev/null
+++ b/recipes/rt2x00/rt3070_2.3.0.4.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Ralink 3070"
+HOMEPAGE = "http://eng.ralinktech.com.tw/support.php?s=2"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+PR = "r0"
+
+inherit module
+
+# Original URL needs a click-wrap license.
+SRC_URI = "http://www.penguin.cz/~utx/hardware/Ralink_3071/DPO_RT3070_LinuxSTA_V${PV}_20100604.tar.bz2 \
+ file://makefile.patch \
+ "
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/DPO_RT3070_LinuxSTA_V${PV}_20100604"
+
+# Source is in .tar.tar.bz2 format.
+do_unpack() {
+ mkdir -p ${WORKDIR}
+ cd ${WORKDIR}
+ bzip2 -dc %s ${DL_DIR}/DPO_RT3070_LinuxSTA_V${PV}_20100604.tar.bz2 | tar x --no-same-owner -O -f - | tar x --no-same-owner -f -
+}
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -m 0644 ${S}/os/linux/rt3070sta.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -d ${D}/etc/Wireless/RT2870STA
+ install -m 0644 ${S}/RT2870STA.dat ${D}/etc/Wireless/RT2870STA
+ install -d ${D}/lib/firmware
+ install -m 0644 ${S}/common/*.bin ${D}/lib/firmware/
+}
+
+PACKAGES =+ "${PN}-firmware"
+FILES_${PN}-firmware = "/etc /lib/firmware"
+
+RDEPENDS_${PN} = "${PN}-firmware"
+
+SRC_URI[md5sum] = "bbfa7a278ae8fa0208499aee048ed1ed"
+SRC_URI[sha256sum] = "df33f63f5396c85ab755bdb9d6c99d40ebfb30f50bd554a1fd6d7a3fb6095db4"