aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rxvt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rxvt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rxvt')
-rw-r--r--recipes/rxvt/rxvt-2.7.9/include.patch16
-rw-r--r--recipes/rxvt/rxvt-2.8.0/include.patch16
-rw-r--r--recipes/rxvt/rxvt_2.7.9.bb41
-rw-r--r--recipes/rxvt/rxvt_2.8.0.bb41
4 files changed, 114 insertions, 0 deletions
diff --git a/recipes/rxvt/rxvt-2.7.9/include.patch b/recipes/rxvt/rxvt-2.7.9/include.patch
new file mode 100644
index 0000000000..f7542843b1
--- /dev/null
+++ b/recipes/rxvt/rxvt-2.7.9/include.patch
@@ -0,0 +1,16 @@
+diff -urN rxvt.orig/src/rxvtlib.h.in rxvt/src/rxvtlib.h.in
+--- rxvt.orig/src/rxvtlib.h.in 2003-03-25 19:13:53.000000000 -0500
++++ rxvt/src/rxvtlib.h.in 2004-04-03 20:35:13.000000000 -0500
+@@ -43,7 +43,11 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+
+-#include <X11/Intrinsic.h> /* Xlib, Xutil, Xresource, Xfuncproto */
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++#include <X11/Xresource.h>
++#include <X11/Xproto.h>
++#include <X11/region.h>
+
+ #ifdef ENABLE_XFT
+ #include <X11/Xft/Xft.h>
diff --git a/recipes/rxvt/rxvt-2.8.0/include.patch b/recipes/rxvt/rxvt-2.8.0/include.patch
new file mode 100644
index 0000000000..f7542843b1
--- /dev/null
+++ b/recipes/rxvt/rxvt-2.8.0/include.patch
@@ -0,0 +1,16 @@
+diff -urN rxvt.orig/src/rxvtlib.h.in rxvt/src/rxvtlib.h.in
+--- rxvt.orig/src/rxvtlib.h.in 2003-03-25 19:13:53.000000000 -0500
++++ rxvt/src/rxvtlib.h.in 2004-04-03 20:35:13.000000000 -0500
+@@ -43,7 +43,11 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+
+-#include <X11/Intrinsic.h> /* Xlib, Xutil, Xresource, Xfuncproto */
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++#include <X11/Xresource.h>
++#include <X11/Xproto.h>
++#include <X11/region.h>
+
+ #ifdef ENABLE_XFT
+ #include <X11/Xft/Xft.h>
diff --git a/recipes/rxvt/rxvt_2.7.9.bb b/recipes/rxvt/rxvt_2.7.9.bb
new file mode 100644
index 0000000000..1d6d586f2a
--- /dev/null
+++ b/recipes/rxvt/rxvt_2.7.9.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Well known terminal emulator"
+SECTION = "x11/utils"
+PR = "r1"
+DEPENDS = "virtual/libx11 libxft"
+LICENSE = "GPL"
+SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \
+ file://include.patch;patch=1"
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt-2.7.9"
+
+S = "${WORKDIR}/rxvt"
+
+EXTRA_OECONF = "--disable-menubar --disable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --with-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --with-x=${STAGING_LIBDIR}/.."
+
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+ echo '#define HAVE_UTMP_H 1' >> config.h
+ echo '#define HAVE_TTYSLOT 1' >> config.h
+}
diff --git a/recipes/rxvt/rxvt_2.8.0.bb b/recipes/rxvt/rxvt_2.8.0.bb
new file mode 100644
index 0000000000..92bb2dcbf5
--- /dev/null
+++ b/recipes/rxvt/rxvt_2.8.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Well known terminal emulator"
+SECTION = "x11/utils"
+PR = "r1"
+DEPENDS = "virtual/libx11 libxft"
+LICENSE = "GPL"
+SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \
+ file://include.patch;patch=1"
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt-2.8.0"
+
+S = "${WORKDIR}/rxvt"
+
+EXTRA_OECONF = "--disable-menubar --disable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --with-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --with-x=${STAGING_LIBDIR}/.."
+
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+ echo '#define HAVE_UTMP_H 1' >> config.h
+ echo '#define HAVE_TTYSLOT 1' >> config.h
+}