aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sablevm/sablevm_1.11.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sablevm/sablevm_1.11.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sablevm/sablevm_1.11.3.bb')
-rw-r--r--recipes/sablevm/sablevm_1.11.3.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/sablevm/sablevm_1.11.3.bb b/recipes/sablevm/sablevm_1.11.3.bb
new file mode 100644
index 0000000000..154745dfeb
--- /dev/null
+++ b/recipes/sablevm/sablevm_1.11.3.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "interpreters"
+
+DEPENDS = "libffi libtool popt \
+ sablevm-classpath"
+# unzip"
+RRECOMMENDS = "sablevm-classpath (>= ${PV})"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--enable-real-life-brokenness \
+ --disable-errors-on-warnings --disable-signals-for-exceptions"
+
+PROVIDES = "virtual/java"
+ALTERNATIVE_NAME = "java"
+ALTERNATIVE_PATH = "${bindir}/java-sablevm"
+ALTERNATIVE_PRIORITY = "350"
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
+
+FILES_${PN} = "${bindir} \
+ ${libdir}/${PN}/bin"
+
+FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
+
+FILES_lib${PN}-dev = "${includedir}/jni* \
+ ${libdir}/lib${PN}.so \
+ ${libdir}/lib${PN}.la"
+
+do_install_append() {
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN} ${D}${docdir}/
+
+ # symlink only present in the deb...
+ install -d ${D}${libdir}/${PN}/bin
+ cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
+}