aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sablevm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sablevm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sablevm')
-rw-r--r--recipes/sablevm/sablevm-classpath/disable-automake-checks.patch11
-rw-r--r--recipes/sablevm/sablevm-classpath_1.1.9.bb21
-rw-r--r--recipes/sablevm/sablevm-classpath_1.11.3.bb26
-rw-r--r--recipes/sablevm/sablevm-classpath_1.12.bb26
-rw-r--r--recipes/sablevm/sablevm/no-internal-libs.patch20
-rw-r--r--recipes/sablevm/sablevm_1.1.9.bb43
-rw-r--r--recipes/sablevm/sablevm_1.11.3.bb42
-rw-r--r--recipes/sablevm/sablevm_1.12.bb52
8 files changed, 241 insertions, 0 deletions
diff --git a/recipes/sablevm/sablevm-classpath/disable-automake-checks.patch b/recipes/sablevm/sablevm-classpath/disable-automake-checks.patch
new file mode 100644
index 0000000000..d6a55428ad
--- /dev/null
+++ b/recipes/sablevm/sablevm-classpath/disable-automake-checks.patch
@@ -0,0 +1,11 @@
+--- sablevm-classpath-1.1.7/configure.ac.orig 2004-11-26 00:23:01.000000000 +0100
++++ sablevm-classpath-1.1.7/configure.ac 2004-11-26 00:23:46.000000000 +0100
+@@ -34,7 +34,7 @@
+ AC_SUBST(CLASSPATH_MODULE)
+
+ AC_PREREQ(2.59)
+-AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar])
++AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local)
+
diff --git a/recipes/sablevm/sablevm-classpath_1.1.9.bb b/recipes/sablevm/sablevm-classpath_1.1.9.bb
new file mode 100644
index 0000000000..c222572009
--- /dev/null
+++ b/recipes/sablevm/sablevm-classpath_1.1.9.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GNU Classpath modified to work with SableVM"
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+SECTION = "libs"
+PR = "r1"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst virtual/javac-native fastjar-native"
+RDEPENDS_${PN} = "${PN}-native"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-compressed-classes=fastjar"
+
+PACKAGES += " ${PN}-native"
+
+FILES_${PN} = "${datadir}/${PN}"
+FILES_${PN}-native = "${libdir}/${PN}"
diff --git a/recipes/sablevm/sablevm-classpath_1.11.3.bb b/recipes/sablevm/sablevm-classpath_1.11.3.bb
new file mode 100644
index 0000000000..0546dcacd6
--- /dev/null
+++ b/recipes/sablevm/sablevm-classpath_1.11.3.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNU Classpath modified to work with SableVM"
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+SECTION = "libs"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst virtual/javac-native zip-native"
+RDEPENDS_${PN} = "${PN}-native (>= ${PV})"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-compressed-classes=zip"
+
+PACKAGES += " ${PN}-native"
+
+FILES_${PN} = "${datadir}/${PN} \
+ ${libdir}/sablevm"
+FILES_${PN}-native = "${libdir}/${PN}"
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}
diff --git a/recipes/sablevm/sablevm-classpath_1.12.bb b/recipes/sablevm/sablevm-classpath_1.12.bb
new file mode 100644
index 0000000000..0380c91ada
--- /dev/null
+++ b/recipes/sablevm/sablevm-classpath_1.12.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNU Classpath modified to work with SableVM"
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+SECTION = "libs"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst virtual/javac-native zip-native"
+RDEPENDS_${PN} = "${PN}-native (>= ${PV})"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sablevm/sablevm-classpath-${PV}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-compressed-classes=zip"
+
+PACKAGES += " ${PN}-native"
+
+FILES_${PN} = "${datadir}/${PN} \
+ ${libdir}/sablevm"
+FILES_${PN}-native = "${libdir}/${PN}"
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}
diff --git a/recipes/sablevm/sablevm/no-internal-libs.patch b/recipes/sablevm/sablevm/no-internal-libs.patch
new file mode 100644
index 0000000000..d082bfd076
--- /dev/null
+++ b/recipes/sablevm/sablevm/no-internal-libs.patch
@@ -0,0 +1,20 @@
+--- sablevm-1.12.orig/src/Makefile.am 2005-07-05 03:10:33.000000000 +0200
++++ sablevm-1.12/src/Makefile.am 2005-07-17 22:30:28.000000000 +0200
+@@ -6,16 +6,8 @@
+ ## * modification of this source file. *
+ ## * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+
+-DIST_SUBDIRS = include libffi libpopt libsablevm sablevm
++DIST_SUBDIRS = include libsablevm sablevm
+
+ SUBDIRS = include
+
+-if CONV_LIBFFI
+-SUBDIRS += libffi
+-endif
+-
+-if CONV_LIBPOPT
+-SUBDIRS += libpopt
+-endif
+-
+ SUBDIRS += libsablevm sablevm
diff --git a/recipes/sablevm/sablevm_1.1.9.bb b/recipes/sablevm/sablevm_1.1.9.bb
new file mode 100644
index 0000000000..7c5198c0e6
--- /dev/null
+++ b/recipes/sablevm/sablevm_1.1.9.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "interpreters"
+PR = "r1"
+
+DEPENDS = "libffi libtool popt \
+ sablevm-classpath"
+# unzip"
+RRECOMMENDS = "sablevm-classpath (${PV})"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--enable-real-life-brokenness \
+ --disable-errors-on-warnings --disable-signals-for-exceptions"
+
+PROVIDES = "virtual/java"
+ALTERNATIVE_NAME = "java"
+ALTERNATIVE_PATH = "${bindir}/java-sablevm"
+ALTERNATIVE_PRIORITY = "350"
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
+
+FILES_${PN} = "${bindir} \
+ ${libdir}/${PN}/bin"
+
+FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
+
+FILES_lib${PN}-dev = "${includedir}/jni* \
+ ${libdir}/lib${PN}.so \
+ ${libdir}/lib${PN}.la"
+
+do_install_append() {
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN} ${D}${docdir}/
+
+ # symlink only present in the deb...
+ install -d ${D}${libdir}/${PN}/bin
+ cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
+}
diff --git a/recipes/sablevm/sablevm_1.11.3.bb b/recipes/sablevm/sablevm_1.11.3.bb
new file mode 100644
index 0000000000..154745dfeb
--- /dev/null
+++ b/recipes/sablevm/sablevm_1.11.3.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "interpreters"
+
+DEPENDS = "libffi libtool popt \
+ sablevm-classpath"
+# unzip"
+RRECOMMENDS = "sablevm-classpath (>= ${PV})"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--enable-real-life-brokenness \
+ --disable-errors-on-warnings --disable-signals-for-exceptions"
+
+PROVIDES = "virtual/java"
+ALTERNATIVE_NAME = "java"
+ALTERNATIVE_PATH = "${bindir}/java-sablevm"
+ALTERNATIVE_PRIORITY = "350"
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
+
+FILES_${PN} = "${bindir} \
+ ${libdir}/${PN}/bin"
+
+FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
+
+FILES_lib${PN}-dev = "${includedir}/jni* \
+ ${libdir}/lib${PN}.so \
+ ${libdir}/lib${PN}.la"
+
+do_install_append() {
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN} ${D}${docdir}/
+
+ # symlink only present in the deb...
+ install -d ${D}${libdir}/${PN}/bin
+ cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
+}
diff --git a/recipes/sablevm/sablevm_1.12.bb b/recipes/sablevm/sablevm_1.12.bb
new file mode 100644
index 0000000000..b39dcf53f6
--- /dev/null
+++ b/recipes/sablevm/sablevm_1.12.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "interpreters"
+
+DEPENDS = "libffi libtool popt \
+ sablevm-classpath"
+# unzip"
+RRECOMMENDS = "sablevm-classpath (>= ${PV})"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sablevm/${PN}-${PV}.tar.gz \
+ file://no-internal-libs.patch;patch=1"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--enable-real-life-brokenness \
+ --disable-errors-on-warnings --disable-signals-for-exceptions"
+
+PROVIDES = "virtual/java"
+ALTERNATIVE_NAME = "java"
+ALTERNATIVE_PATH = "${bindir}/java-sablevm"
+ALTERNATIVE_PRIORITY = "350"
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
+
+FILES_${PN} = "${bindir} \
+ ${libdir}/${PN}/bin"
+
+FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
+
+FILES_lib${PN}-dev = "${includedir}/jni* \
+ ${libdir}/lib${PN}.so \
+ ${libdir}/lib${PN}.la"
+
+do_configure() {
+ # remove internal copies of libpopt and libffi
+ rm -rf src/libpopt src/libffi
+
+ autotools_do_configure
+}
+
+do_install() {
+ autotools_do_install
+
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN} ${D}${docdir}/
+
+ # symlink only present in the deb...
+ install -d ${D}${libdir}/${PN}/bin
+ cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
+}