aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samba
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/samba
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/samba')
-rw-r--r--recipes/samba/samba-ads_3.2.15.bb10
-rw-r--r--recipes/samba/samba-ads_3.3.9.bb10
-rw-r--r--recipes/samba/samba-basic.inc4
-rw-r--r--recipes/samba/samba-essential.inc4
-rw-r--r--recipes/samba/samba-essential_3.0.20.bb4
-rw-r--r--recipes/samba/samba_3.0.23c.bb4
-rw-r--r--recipes/samba/samba_3.0.34.bb6
-rw-r--r--recipes/samba/samba_3.2.15.bb6
-rw-r--r--recipes/samba/samba_3.3.0.bb8
-rw-r--r--recipes/samba/samba_3.3.9.bb8
10 files changed, 32 insertions, 32 deletions
diff --git a/recipes/samba/samba-ads_3.2.15.bb b/recipes/samba/samba-ads_3.2.15.bb
index 264ba07a83..17269f3aee 100644
--- a/recipes/samba/samba-ads_3.2.15.bb
+++ b/recipes/samba/samba-ads_3.2.15.bb
@@ -3,11 +3,11 @@ require samba-ads.inc
LICENSE = "GPLv3"
PR = "r2"
-SRC_URI += "file://config-lfs.patch;apply=yes \
- file://quota.patch;apply=yes;striplevel=0 \
- file://configure-3.2.8.patch;apply=yes \
- file://config-h.patch;apply=yes \
- file://mtab.patch;apply=yes \
+SRC_URI += "file://config-lfs.patch \
+ file://quota.patch;striplevel=0 \
+ file://configure-3.2.8.patch \
+ file://config-h.patch \
+ file://mtab.patch \
"
SRC_URI[src.md5sum] = "5a3bcc4927c9643b9f42970d0815b18f"
SRC_URI[src.sha256sum] = "84281fd1faeffee8558e49dff865dd382abbf78bc1be00f8cb5aa70aeea67d46"
diff --git a/recipes/samba/samba-ads_3.3.9.bb b/recipes/samba/samba-ads_3.3.9.bb
index 42300184bc..6407764c52 100644
--- a/recipes/samba/samba-ads_3.3.9.bb
+++ b/recipes/samba/samba-ads_3.3.9.bb
@@ -3,11 +3,11 @@ require samba-ads.inc
LICENSE = "GPLv3"
PR = "r3"
-SRC_URI += "file://config-lfs.patch;apply=yes \
- file://quota.patch;apply=yes;striplevel=0 \
- file://configure-3.3.0.patch;apply=yes \
- file://config-h.patch;apply=yes \
- file://mtab.patch;apply=yes \
+SRC_URI += "file://config-lfs.patch \
+ file://quota.patch;striplevel=0 \
+ file://configure-3.3.0.patch \
+ file://config-h.patch \
+ file://mtab.patch \
"
do_compile () {
diff --git a/recipes/samba/samba-basic.inc b/recipes/samba/samba-basic.inc
index 9dda9e8439..362762a710 100644
--- a/recipes/samba/samba-basic.inc
+++ b/recipes/samba/samba-basic.inc
@@ -1,5 +1,5 @@
-SRC_URI += "file://config-lfs.patch;apply=yes \
- file://quota.patch;apply=yes;striplevel=0 \
+SRC_URI += "file://config-lfs.patch \
+ file://quota.patch;striplevel=0 \
"
EXTRA_OECONF += "\
diff --git a/recipes/samba/samba-essential.inc b/recipes/samba/samba-essential.inc
index d62f5d192e..0067265f02 100644
--- a/recipes/samba/samba-essential.inc
+++ b/recipes/samba/samba-essential.inc
@@ -3,8 +3,8 @@ LICENSE = "GPL"
DEPENDS = "readline"
SRC_URI = "http://samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://configure.patch;apply=yes \
- file://cifs.patch;apply=yes"
+ file://configure.patch \
+ file://cifs.patch"
S = "${WORKDIR}/samba-${PV}/source"
inherit autotools
diff --git a/recipes/samba/samba-essential_3.0.20.bb b/recipes/samba/samba-essential_3.0.20.bb
index b3bd21f84a..f3c2584d63 100644
--- a/recipes/samba/samba-essential_3.0.20.bb
+++ b/recipes/samba/samba-essential_3.0.20.bb
@@ -3,9 +3,9 @@ inherit update-rc.d
PR = "r7"
-SRC_URI = "file://config-lfs.patch;apply=yes \
+SRC_URI = "file://config-lfs.patch \
file://init-essential \
- file://quota.patch;apply=yes;striplevel=0 \
+ file://quota.patch;striplevel=0 \
file://smb-essential.conf \
file://smb-essential-inactive.conf \
file://Managing-Samba.txt"
diff --git a/recipes/samba/samba_3.0.23c.bb b/recipes/samba/samba_3.0.23c.bb
index e890337054..c99ba06510 100644
--- a/recipes/samba/samba_3.0.23c.bb
+++ b/recipes/samba/samba_3.0.23c.bb
@@ -1,8 +1,8 @@
require samba.inc
require samba-basic.inc
-SRC_URI += "file://configure.patch;apply=yes \
- file://cifs.patch;apply=yes"
+SRC_URI += "file://configure.patch \
+ file://cifs.patch"
PR = "r7"
diff --git a/recipes/samba/samba_3.0.34.bb b/recipes/samba/samba_3.0.34.bb
index dc97866134..54a6b0a907 100644
--- a/recipes/samba/samba_3.0.34.bb
+++ b/recipes/samba/samba_3.0.34.bb
@@ -1,10 +1,10 @@
require samba.inc
require samba-basic.inc
-SRC_URI += "file://configure.patch;apply=yes \
+SRC_URI += "file://configure.patch \
"
-SRC_URI_append_linux-uclibc = "file://uclibc-strlcpy-strlcat.patch;apply=yes"
-SRC_URI_append_linux-uclibceabi = "file://uclibc-strlcpy-strlcat.patch;apply=yes"
+SRC_URI_append_linux-uclibc = "file://uclibc-strlcpy-strlcat.patch"
+SRC_URI_append_linux-uclibceabi = "file://uclibc-strlcpy-strlcat.patch"
PR = "r5"
diff --git a/recipes/samba/samba_3.2.15.bb b/recipes/samba/samba_3.2.15.bb
index 6df396acba..d5ec4ff562 100644
--- a/recipes/samba/samba_3.2.15.bb
+++ b/recipes/samba/samba_3.2.15.bb
@@ -2,9 +2,9 @@ require samba.inc
require samba-basic.inc
LICENSE = "GPLv3"
-SRC_URI += "file://configure-3.2.8.patch;apply=yes \
- file://config-h.patch;apply=yes \
- file://mtab.patch;apply=yes \
+SRC_URI += "file://configure-3.2.8.patch \
+ file://config-h.patch \
+ file://mtab.patch \
"
SRC_URI[src.md5sum] = "5a3bcc4927c9643b9f42970d0815b18f"
SRC_URI[src.sha256sum] = "84281fd1faeffee8558e49dff865dd382abbf78bc1be00f8cb5aa70aeea67d46"
diff --git a/recipes/samba/samba_3.3.0.bb b/recipes/samba/samba_3.3.0.bb
index 2796152f09..cebcc178e9 100644
--- a/recipes/samba/samba_3.3.0.bb
+++ b/recipes/samba/samba_3.3.0.bb
@@ -8,10 +8,10 @@ LICENSE = "GPLv3"
# should there be further issues. Appears to work though :)
DEFAULT_PREFERENCE = "-1"
-SRC_URI += "file://configure-3.3.0.patch;apply=yes \
- file://config-h.patch;apply=yes \
- file://mtab.patch;apply=yes \
- file://tdbheaderfix.patch;apply=yes "
+SRC_URI += "file://configure-3.3.0.patch \
+ file://config-h.patch \
+ file://mtab.patch \
+ file://tdbheaderfix.patch "
PR = "r3"
diff --git a/recipes/samba/samba_3.3.9.bb b/recipes/samba/samba_3.3.9.bb
index 40828d64b4..00fef0fc10 100644
--- a/recipes/samba/samba_3.3.9.bb
+++ b/recipes/samba/samba_3.3.9.bb
@@ -8,10 +8,10 @@ LICENSE = "GPLv3"
# should there be further issues. Appears to work though :)
DEFAULT_PREFERENCE = "-1"
-SRC_URI += "file://configure-3.3.0.patch;apply=yes \
- file://config-h.patch;apply=yes \
- file://mtab.patch;apply=yes \
- file://tdbheaderfix.patch;apply=yes "
+SRC_URI += "file://configure-3.3.0.patch \
+ file://config-h.patch \
+ file://mtab.patch \
+ file://tdbheaderfix.patch "
PR = "r3"