aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/scap
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/scap
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/scap')
-rw-r--r--recipes/scap/files/scap.desktop9
-rw-r--r--recipes/scap/files/scap.pngbin0 -> 628 bytes
-rw-r--r--recipes/scap/files/scap.sh20
-rw-r--r--recipes/scap/scap_0.1.bb15
4 files changed, 44 insertions, 0 deletions
diff --git a/recipes/scap/files/scap.desktop b/recipes/scap/files/scap.desktop
new file mode 100644
index 0000000000..bba17259bb
--- /dev/null
+++ b/recipes/scap/files/scap.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Upload Screenshot
+Comment=Upload a screenshot to http://handhelds.org/scap
+Exec=scap
+Terminal=0
+Type=Application
+Icon=scap.png
+Categories=Action
+StartupNotify=False
diff --git a/recipes/scap/files/scap.png b/recipes/scap/files/scap.png
new file mode 100644
index 0000000000..ed7f09fd72
--- /dev/null
+++ b/recipes/scap/files/scap.png
Binary files differ
diff --git a/recipes/scap/files/scap.sh b/recipes/scap/files/scap.sh
new file mode 100644
index 0000000000..ea3ff24593
--- /dev/null
+++ b/recipes/scap/files/scap.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+sleep 2
+if [ -x /usr/bin/bl ]; then
+ bl off
+fi
+MODEL=`cat /proc/cpuinfo | grep ^Hardware | sed "s/.* //"`
+test -e /etc/scap.conf && USER=`cat /etc/scap.conf`
+RES=`fbset 2>/dev/null | awk "/geometry/ { print \$2 "x" \$3 }"`
+(echo "POST /scap/capture.cgi?$MODEL+$USER+$RES HTTP/1.1"
+ echo -n Content-length:
+ cat /dev/fb0 | wc -c
+ echo "Content-Type: image/gif"
+ echo "Host: www.handhelds.org"
+ echo ""
+ cat /dev/fb0) | nc www.handhelds.org 80
+if [ -x /usr/bin/bl ]; then
+ bl on
+fi
+
diff --git a/recipes/scap/scap_0.1.bb b/recipes/scap/scap_0.1.bb
new file mode 100644
index 0000000000..9ba295a7a5
--- /dev/null
+++ b/recipes/scap/scap_0.1.bb
@@ -0,0 +1,15 @@
+LICENSE = "OSL"
+PR = "r5"
+
+DESCRIPTION = "handhelds.org screen capture utility"
+SRC_URI = "file://scap.sh file://scap.desktop file://scap.png"
+
+do_install() {
+ install -d ${D}${bindir}
+ install ${WORKDIR}/scap.sh ${D}${bindir}/scap
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/scap.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/scap.png ${D}${datadir}/pixmaps/
+}
+