aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/scew
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/scew
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/scew')
-rw-r--r--recipes/scew/scew-0.3.1/m4.patch70
-rw-r--r--recipes/scew/scew_0.3.1.bb9
2 files changed, 79 insertions, 0 deletions
diff --git a/recipes/scew/scew-0.3.1/m4.patch b/recipes/scew/scew-0.3.1/m4.patch
new file mode 100644
index 0000000000..1ada688dd8
--- /dev/null
+++ b/recipes/scew/scew-0.3.1/m4.patch
@@ -0,0 +1,70 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null
++++ scew-0.3.1/m4/doxygen.m4
+@@ -0,0 +1,62 @@
++#
++# $Id: doxygen.m4,v 1.1 2003/07/09 21:56:03 aleix Exp $
++#
++# Author: Aleix Conchillo Flaque <aleix@member.fsf.org>
++# Start date: Sun Jul 06, 2003 04:41
++#
++# Copyright (C) 2003 Aleix Conchillo Flaque
++#
++
++# Locate doxygen and auxiliary programs.
++# SCEW_DOXYGEN declares the configure arguments
++# doxygen
++# dot
++# html-docs
++# latex-docs
++# The conditional macro DOC marks whether doxygen is enabled
++# (or found, if not disabled). In the doxyfile.in file,
++# @enable_dot@
++# @enable_html_docs@
++# @enable_latex_docs@
++# can be used to setup the documentation's generation.
++
++AC_DEFUN(SCEW_DOXYGEN,
++[
++AC_ARG_ENABLE(doxygen,
++[ --enable-doxygen enable documentation generation with doxygen (auto)])
++AC_ARG_ENABLE(dot,
++[ --enable-dot use 'dot' to generate graphs in doxygen (auto)])
++AC_ARG_ENABLE(html-docs,
++[ --enable-html-docs enable HTML generation with doxygen (yes)], [], [ enable_html_docs=yes])
++AC_ARG_ENABLE(latex-docs,
++[ --enable-latex-docs enable LaTeX documentation generation with doxygen (no)], [], [ enable_latex_docs=no])
++
++if test "x$enable_doxygen" = xno; then
++ enable_doc=no
++else
++ AC_PATH_PROG(DOXYGEN, doxygen, , $PATH)
++ if test x$DOXYGEN = x; then
++ if test "x$enable_doxygen" = xyes; then
++ AC_MSG_ERROR([could not find doxygen])
++ fi
++ enable_doc=no
++ else
++ enable_doc=yes
++ AC_PATH_PROG(DOT, dot, , $PATH)
++ fi
++fi
++AM_CONDITIONAL(DOC, test x$enable_doc = xyes)
++
++if test x$DOT = x; then
++ if test "x$enable_dot" = xyes; then
++ AC_MSG_ERROR([could not find dot])
++ fi
++ enable_dot=no
++else
++ enable_dot=yes
++fi
++AC_SUBST(enable_dot)
++AC_SUBST(enable_html_docs)
++AC_SUBST(enable_latex_docs)
++])
++
diff --git a/recipes/scew/scew_0.3.1.bb b/recipes/scew/scew_0.3.1.bb
new file mode 100644
index 0000000000..6abde6b012
--- /dev/null
+++ b/recipes/scew/scew_0.3.1.bb
@@ -0,0 +1,9 @@
+SECTION = "libs"
+DESCRIPTION = "Simple C Expat Wrapper."
+DEPENDS = "expat"
+LICENSE = "LGPL"
+SRC_URI = "http://savannah.nongnu.org/download/scew/scew-${PV}.tar.gz \
+ file://m4.patch;patch=1"
+PR = "r1"
+
+inherit autotools pkgconfig