summaryrefslogtreecommitdiffstats
path: root/recipes/schedstat-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/schedstat-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/schedstat-utils')
-rw-r--r--recipes/schedstat-utils/schedstat-utils.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/schedstat-utils/schedstat-utils.bb b/recipes/schedstat-utils/schedstat-utils.bb
new file mode 100644
index 0000000000..051135a9fb
--- /dev/null
+++ b/recipes/schedstat-utils/schedstat-utils.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Simple utilities for using the information exposed by \
+'schedstats', the kernel patches for obtaining scheduler statistics."
+
+SRC_URI = "http://eaglet.rain.com/rick/linux/schedstat/v10/latency.c \
+ http://eaglet.rain.com/rick/linux/schedstat/v10/stats-10.pl"
+S = "${WORKDIR}/eaglet.rain.com"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} latency.c -o stats-latency
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 stats-latency ${D}${sbindir}/
+ install -m 0755 stats-10.pl ${D}${sbindir}/
+}
+
+PACKAGES = "${PN}-dbg schedstat-utils \
+ schedstat-utils-latency \
+ schedstat-utils-perl"
+RDEPENDS_${PN} = "schedstat-utils-latency schedstat-utils-perl"
+RDEPENDS_schedstat-utils-perl += "perl"
+FILES_${PN} = ""
+FILES_schedstat-utils-latency = "${sbindir}/stats-latency"
+FILES_schedstat-utils-perl = "${sbindir}/stats-10.pl"