aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/schroedinger
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-18 12:27:34 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-18 13:27:35 -0700
commitf838e470b70a579316cdbb18cfeb0b75baee00e3 (patch)
tree90e2ecc7999faf2e7527c55648d5768d7b1a7dec /recipes/schroedinger
parenta615cbed3cd39605679c951fd92a59bc9d8de126 (diff)
downloadopenembedded-f838e470b70a579316cdbb18cfeb0b75baee00e3.tar.gz
schroedinger: Fix RPATH QA errors
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/schroedinger')
-rw-r--r--recipes/schroedinger/schroedinger.inc8
-rw-r--r--recipes/schroedinger/schroedinger_1.0.9.bb2
2 files changed, 8 insertions, 2 deletions
diff --git a/recipes/schroedinger/schroedinger.inc b/recipes/schroedinger/schroedinger.inc
index 7819814fc0..4dc8a6e42f 100644
--- a/recipes/schroedinger/schroedinger.inc
+++ b/recipes/schroedinger/schroedinger.inc
@@ -2,7 +2,7 @@ HOMEPAGE = "http://schrodinger.sourceforge.net/"
LICENSE = "MPL GPL LGPL MIT"
DEPENDS = "liboil orc-native orc"
-PR = "r0"
+INC_PR = "r1"
SRC_URI = "http://www.diracvideo.org/download/schroedinger/${P}.tar.gz;name=schroedingertargz"
SRC_URI[schroedingertargz.md5sum] = "d67ec48b7c506db8c8b49156bf409e60"
@@ -13,3 +13,9 @@ EXTRA_OECONF += "STAGING_DIR=${STAGING_DIR_NATIVE}"
inherit autotools
+do_configure_append () {
+ # Fix stupid libtool... handling.
+ # rpath handling can't be disabled and the Makefile's can't be regenerated..
+ # (GNU sed required)
+ sed -i s/^hardcode_libdir_flag_spec/#hardcode_libdir_flag_spec/ ${S}/*-libtool
+}
diff --git a/recipes/schroedinger/schroedinger_1.0.9.bb b/recipes/schroedinger/schroedinger_1.0.9.bb
index 9826995d96..299442883e 100644
--- a/recipes/schroedinger/schroedinger_1.0.9.bb
+++ b/recipes/schroedinger/schroedinger_1.0.9.bb
@@ -1,6 +1,6 @@
require schroedinger.inc
-PR = "r0"
+PR = "${INC_PR}.0"
inherit autotools