summaryrefslogtreecommitdiffstats
path: root/recipes/scratchbox
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-26 16:41:45 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-26 16:43:08 -0700
commit97222a4ffc9543e4c687755614512e43d439983f (patch)
treef458ba46f260b330b40ef928268b33bed5291c68 /recipes/scratchbox
parent9feccf3a7374f6ac7ffe2ec42855585c6ccdf515 (diff)
downloadopenembedded-97222a4ffc9543e4c687755614512e43d439983f.tar.gz
sbrsh: Fix complilation with gcc 4.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/scratchbox')
-rw-r--r--recipes/scratchbox/sbrsh-7.1/add-limits.h.patch13
-rw-r--r--recipes/scratchbox/sbrsh_7.1.bb6
2 files changed, 17 insertions, 2 deletions
diff --git a/recipes/scratchbox/sbrsh-7.1/add-limits.h.patch b/recipes/scratchbox/sbrsh-7.1/add-limits.h.patch
new file mode 100644
index 0000000000..ad113977e1
--- /dev/null
+++ b/recipes/scratchbox/sbrsh-7.1/add-limits.h.patch
@@ -0,0 +1,13 @@
+Index: sbrsh-7.1/client.c
+===================================================================
+--- sbrsh-7.1.orig/client.c
++++ sbrsh-7.1/client.c
+@@ -31,7 +31,7 @@
+ #include <sys/time.h>
+ #include <sys/stat.h>
+ #include <netinet/in.h>
+-
++#include <limits.h>
+
+ #define REQUIRED_VERSION 6
+
diff --git a/recipes/scratchbox/sbrsh_7.1.bb b/recipes/scratchbox/sbrsh_7.1.bb
index 5a11ca86e9..cc9882e2d2 100644
--- a/recipes/scratchbox/sbrsh_7.1.bb
+++ b/recipes/scratchbox/sbrsh_7.1.bb
@@ -2,10 +2,12 @@ DESCRIPTION = "Daemon to allow scratchbox to use your device as a CPU tranparenc
HOMEPAGE = "http://scratchbox.org"
LICENSE = "GPLv2"
DEPENDS = "fakeroot"
-PR = "r2"
+PR = "r3"
RRECOMMENDS_${PN} = "kernel-module-nfs"
-SRC_URI = "http://scratchbox.org/download/files/sbox-releases/1.0/src/${P}.tar.gz"
+SRC_URI = "http://scratchbox.org/download/files/sbox-releases/1.0/src/${P}.tar.gz \
+ file://add-limits.h.patch \
+ "
do_install() {
install -d ${D}${sbindir}