aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sdcc/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sdcc/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sdcc/files')
-rw-r--r--recipes/sdcc/files/gcc4.patch13
-rw-r--r--recipes/sdcc/files/use-native-tools.patch80
2 files changed, 93 insertions, 0 deletions
diff --git a/recipes/sdcc/files/gcc4.patch b/recipes/sdcc/files/gcc4.patch
new file mode 100644
index 0000000000..31eed50df8
--- /dev/null
+++ b/recipes/sdcc/files/gcc4.patch
@@ -0,0 +1,13 @@
+Index: sdcc/sim/ucsim/cmd.src/newcmdcl.h
+===================================================================
+--- sdcc.orig/sim/ucsim/cmd.src/newcmdcl.h
++++ sdcc/sim/ucsim/cmd.src/newcmdcl.h
+@@ -124,7 +124,7 @@ public:
+ cl_console(int portnumber, class cl_app *the_app);
+ #endif
+ virtual ~cl_console(void);
+- virtual class cl_console *cl_console::clone_for_exec(char *fin);
++ virtual class cl_console *clone_for_exec(char *fin);
+ virtual int init(void);
+
+ virtual bool accept_last(void);
diff --git a/recipes/sdcc/files/use-native-tools.patch b/recipes/sdcc/files/use-native-tools.patch
new file mode 100644
index 0000000000..d3b02c4a44
--- /dev/null
+++ b/recipes/sdcc/files/use-native-tools.patch
@@ -0,0 +1,80 @@
+Index: sdcc/device/lib/Makefile.in
+===================================================================
+--- sdcc.orig/device/lib/Makefile.in
++++ sdcc/device/lib/Makefile.in
+@@ -18,8 +18,8 @@ ifndef PORTINCDIR
+ PORTINCDIR = $(INCDIR)/mcs51
+ endif
+
+-CC = $(PRJDIR)/bin/sdcc
+-CPP = $(PRJDIR)/bin/sdcpp
++CC = sdcc
++CPP = sdcpp
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+Index: sdcc/device/lib/mcs51/Makefile
+===================================================================
+--- sdcc.orig/device/lib/mcs51/Makefile
++++ sdcc/device/lib/mcs51/Makefile
+@@ -1,8 +1,8 @@
+
+ TOPDIR = ../../..
+
+-SAS = $(TOPDIR)/bin/asx8051
+-SCC = $(TOPDIR)/bin/sdcc
++SAS = asx8051
++SCC = sdcc
+
+ OBJ = crtstart.rel crtxinit.rel crtxclear.rel crtclear.rel crtxstack.rel \
+ crtpagesfr.rel
+Index: sdcc/device/lib/ds390/Makefile
+===================================================================
+--- sdcc.orig/device/lib/ds390/Makefile
++++ sdcc/device/lib/ds390/Makefile
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+Index: sdcc/device/lib/ds400/Makefile
+===================================================================
+--- sdcc.orig/device/lib/ds400/Makefile
++++ sdcc/device/lib/ds400/Makefile
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+Index: sdcc/device/lib/z80/Makefile
+===================================================================
+--- sdcc.orig/device/lib/z80/Makefile
++++ sdcc/device/lib/z80/Makefile
+@@ -2,8 +2,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mz80
+-SAS = $(TOPDIR)/bin/as-z80
++SCC = sdcc -mz80
++SAS = as-z80
+
+ OBJ = div.o mul.o putchar.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+
+Index: sdcc/device/lib/gbz80/Makefile
+===================================================================
+--- sdcc.orig/device/lib/gbz80/Makefile
++++ sdcc/device/lib/gbz80/Makefile
+@@ -2,8 +2,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mgbz80
+-SAS = $(TOPDIR)/bin/as-gbz80
++SCC = sdcc -mgbz80
++SAS = as-gbz80
+
+ OBJ = div.o mul.o putchar.o printf.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+