aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sdlperl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sdlperl
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sdlperl')
-rw-r--r--recipes/sdlperl/Makefile.patch17
-rw-r--r--recipes/sdlperl/sdl-perl_1.20.3.bb18
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/sdlperl/Makefile.patch b/recipes/sdlperl/Makefile.patch
new file mode 100644
index 0000000000..ae20c08c77
--- /dev/null
+++ b/recipes/sdlperl/Makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.linux.orig 2004-06-25 12:44:53.000000000 +0100
++++ Makefile.linux 2004-06-25 12:45:37.000000000 +0100
+@@ -119,12 +119,12 @@
+ my %options = (
+ 'NAME' => 'SDL_perl',
+ 'VERSION_FROM' => 'lib/SDL.pm',
+- 'LIBS' => [ join( " ", "$sdl_libs",
++ 'LIBS' => [ join( " ", $ENV{"LDFLAGS"}, "$sdl_libs",
+ map { $ext{$_}{exists} ? "-l$_" : '' } (sort keys %ext),
+ )
+ ],
+ 'DEFINE' => join ( " ", @defs, map { $ext{$_}{exists} ? "-D$ext{$_}{inc}" : '' } sort keys %ext),
+- 'INC' => "$inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
++ 'INC' => $ENV{"CFLAGS"} . " $inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
+ 'OBJECT' => (
+ ($ext{SDL_image}{exists} ? 'SFont.o ' : "") .
+ 'SDL_perl.o ' .
diff --git a/recipes/sdlperl/sdl-perl_1.20.3.bb b/recipes/sdlperl/sdl-perl_1.20.3.bb
new file mode 100644
index 0000000000..6820fa05ce
--- /dev/null
+++ b/recipes/sdlperl/sdl-perl_1.20.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Perl bindings for SDL"
+SECTION = "libs"
+HOMEPAGE = "http://sdl.perl.org/"
+LICENSE = "GPL"
+DEPENDS = "perl virtual/libsdl libsdl-image libsdl-gfx libsdl-ttf libsdl-mixer libsdl-net smpeg"
+PR = "r1"
+
+SRC_URI = "http://bloodgate.com/perl/sdl/pub/SDL_perl-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_perl-${PV}"
+
+inherit cpan
+
+do_configure_prepend() {
+ # Search staging area for includes
+ sed -i -e 's:/usr/\(local/\)\{0,1\}include:${STAGING_INCDIR}:g' Makefile.linux
+ # smpeg.h isn't in a subdirectry
+ sed -i -e 's:#include <smpeg/smpeg.h>:#include <smpeg.h>:g' SDL_perl.xs
+}