aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sdr
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-12-31 13:47:05 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-31 13:47:05 +0100
commitf4b014d3a680d6560b679e856a0c4b58d3d53361 (patch)
tree64fa0e78619dd0f79cf1e55355c5f84bb818ddc4 /recipes/sdr
parent17da16b6b1229044773661bd1060febf113297c8 (diff)
downloadopenembedded-f4b014d3a680d6560b679e856a0c4b58d3d53361.tar.gz
sdrshell: add qt4 version
Diffstat (limited to 'recipes/sdr')
-rw-r--r--recipes/sdr/sdrshell-qt4_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/sdr/sdrshell-qt4_svn.bb b/recipes/sdr/sdrshell-qt4_svn.bb
new file mode 100644
index 0000000000..ec81f96f60
--- /dev/null
+++ b/recipes/sdr/sdrshell-qt4_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "SDR-Shell is Qt GUI for the sdr-core (DttSP) Software Defined Radio"
+LICENSE = "GPLv2"
+
+DEPENDS = "dttsp"
+
+inherit qt4x11
+
+SRCREV = "129"
+PV = "${SRCREV}"
+
+SRC_URI = "svn://sdr-shell.googlecode.com/svn/branches;module=sdr-shell-v4;proto=http \
+"
+S = "${WORKDIR}/sdr-shell-v4"
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ rm -f ${S}/sdr-shell
+}
+
+do_compile_prepend() {
+ sed -i -e s:OE_QMAKE_LINK:CXX:g ${S}/Makefile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/sdr-shell ${D}${bindir}
+}
+
+