aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/serial-utils
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-14 17:46:00 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-14 17:46:36 +0100
commitbc68ed7c92effcdc7b475286bf1c3ac2f772f073 (patch)
tree19caa209c21ab0defd8ad705c98ef011025e8a59 /recipes/serial-utils
parent2e3f7f97267390bd0c70a41a9f58948f860bc66b (diff)
downloadopenembedded-bc68ed7c92effcdc7b475286bf1c3ac2f772f073.tar.gz
serial-forward: catch up with conversion to autotools
pty-forward-native: dito
Diffstat (limited to 'recipes/serial-utils')
-rw-r--r--recipes/serial-utils/pty-forward-native.bb15
-rw-r--r--recipes/serial-utils/serial-forward.bb14
2 files changed, 6 insertions, 23 deletions
diff --git a/recipes/serial-utils/pty-forward-native.bb b/recipes/serial-utils/pty-forward-native.bb
index c613276645..0cc21e1fc6 100644
--- a/recipes/serial-utils/pty-forward-native.bb
+++ b/recipes/serial-utils/pty-forward-native.bb
@@ -2,26 +2,17 @@ DESCRIPTION = "Receive a forwarded serial from serial-forward and provide a PTY"
AUTHOR = "Holger 'Zecke' Freyther"
LICENSE = "GPL"
SECTION = "console/network"
-PV = "1.0.1+gitr${SRCREV}"
+PV = "1.1+gitr${SRCREV}"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git"
S = "${WORKDIR}/git/tools/serial_forward"
-inherit native
-
-do_compile() {
- cd ${S}
- oe_runmake
-}
-
-do_stage() {
- :
-}
+inherit autotools native
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+ install -m 0755 ${S}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
}
addtask deploy before do_package after do_install
diff --git a/recipes/serial-utils/serial-forward.bb b/recipes/serial-utils/serial-forward.bb
index b03fc597dd..8645b85c71 100644
--- a/recipes/serial-utils/serial-forward.bb
+++ b/recipes/serial-utils/serial-forward.bb
@@ -2,18 +2,10 @@ DESCRIPTION = "Forward a serial using TCP/IP"
AUTHOR = "Holger 'Zecke' Freyther'"
LICENSE = "GPL"
SECTION = "console/devel"
-PV = "1.0.1+gitr${SRCREV}"
-PR = "r1"
+PV = "1.1+gitr${SRCREV}"
+PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git/;protocol=git"
S = "${WORKDIR}/git/tools/serial_forward"
-EXTRA_OEMAKE = "CC="${CC} ${LDFLAGS}""
-do_compile() {
- cd ${S}
- oe_runmake
-}
-do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
-}
+inherit autotools