aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sgml-common
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2010-08-24 02:32:43 +0000
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-24 17:53:02 +0200
commit167ad00f3819a0b300cc0d3daac6c16962c6c3a7 (patch)
treed01a8a1d40bad08715ae3e46843c569b8c5ab101 /recipes/sgml-common
parent2fd903f4f6b0c967789e3e74aec6106359b16582 (diff)
downloadopenembedded-167ad00f3819a0b300cc0d3daac6c16962c6c3a7.tar.gz
sgml-common-native: Run oe-stylize.py and updated the recipe accordingly
* Run oe-stylize.py on the recipe and updated the recipe according to the output of oe-stylize.py * Remove FILESDIR variable Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Diffstat (limited to 'recipes/sgml-common')
-rw-r--r--recipes/sgml-common/sgml-common-native_0.6.3.bb62
1 files changed, 29 insertions, 33 deletions
diff --git a/recipes/sgml-common/sgml-common-native_0.6.3.bb b/recipes/sgml-common/sgml-common-native_0.6.3.bb
index 6f61a23870..67f1710a4f 100644
--- a/recipes/sgml-common/sgml-common-native_0.6.3.bb
+++ b/recipes/sgml-common/sgml-common-native_0.6.3.bb
@@ -1,41 +1,37 @@
SECTION = "base"
-require sgml-common_${PV}.bb
-inherit native
-
DEPENDS = ""
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/sgml-common-${PV}"
-S = "${WORKDIR}/sgml-common-${PV}"
-PACKAGES = ""
-do_stage () {
- # For unknown reasons 'make install' does not work.
- install -m 0755 bin/install-catalog ${STAGING_BINDIR_NATIVE}/
- install -m 0755 bin/sgmlwhich ${STAGING_BINDIR_NATIVE}/
-
- install -d ${sysconfdir}/sgml
- install -m 0644 config/sgml.conf ${sysconfdir}/sgml
-
- install -d ${STAGING_DATADIR}/sgml
- install -m 0644 xml.dcl ${STAGING_DATADIR}/sgml/
-
- install -d ${STAGING_DATADIR}/sgml/xml-iso-entities-8879.1986
- install -m 0644 xml-iso-entities/catalog ${STAGING_DATADIR}/sgml/xml-iso-entities-8879.1986/
- install -m 0644 xml-iso-entities/*.ent ${STAGING_DATADIR}/sgml/xml-iso-entities-8879.1986/
- install -d ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986
- install -m 0644 sgml-iso-entities/catalog ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986/
- install -m 0644 sgml-iso-entities/*.ent ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986/
+SRC_URI[md5sum] = "103c9828f24820df86e55e7862e28974"
+SRC_URI[sha256sum] = "7dc418c1d361123ffc5e45d61f1b97257940a8eb35d0bfbbc493381cc5b1f959"
- install-catalog \
- --add ${sysconfdir}/sgml/sgml-ent.cat ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986/catalog
-
- install-catalog \
- --add ${sysconfdir}/sgml/sgml-docbook.cat ${sysconfdir}/sgml/sgml-ent.cat
-
-}
+S = "${WORKDIR}/sgml-common-${PV}"
+
+require sgml-common_${PV}.bb
+inherit native
do_install () {
- :
+ :
+}
+do_stage () {
+ # For unknown reasons 'make install' does not work.
+ install -m 0755 bin/install-catalog ${STAGING_BINDIR_NATIVE}/
+ install -m 0755 bin/sgmlwhich ${STAGING_BINDIR_NATIVE}/
+ install -d ${sysconfdir}/sgml
+ install -m 0644 config/sgml.conf ${sysconfdir}/sgml
+ install -d ${STAGING_DATADIR}/sgml
+ install -m 0644 xml.dcl ${STAGING_DATADIR}/sgml/
+ install -d ${STAGING_DATADIR}/sgml/xml-iso-entities-8879.1986
+ install -m 0644 xml-iso-entities/catalog ${STAGING_DATADIR}/sgml/xml-iso-entities-8879.1986/
+ install -m 0644 xml-iso-entities/*.ent ${STAGING_DATADIR}/sgml/xml-iso-entities-8879.1986/
+ install -d ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986
+ install -m 0644 sgml-iso-entities/catalog ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986/
+ install -m 0644 sgml-iso-entities/*.ent ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986/
+ install-catalog \
+ --add ${sysconfdir}/sgml/sgml-ent.cat ${STAGING_DATADIR}/sgml/sgml-iso-entities-8879.1986/catalog
+ install-catalog \
+ --add ${sysconfdir}/sgml/sgml-docbook.cat ${sysconfdir}/sgml/sgml-ent.cat
}
-SRC_URI[md5sum] = "103c9828f24820df86e55e7862e28974"
-SRC_URI[sha256sum] = "7dc418c1d361123ffc5e45d61f1b97257940a8eb35d0bfbbc493381cc5b1f959"
+PACKAGES = ""
+
+