aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sharp-binary-only/sharp-aticore-oss-1.0.1
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sharp-binary-only/sharp-aticore-oss-1.0.1')
-rw-r--r--recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/aticore-2.6.patch82
-rw-r--r--recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/fixstretchblit.patch30
-rw-r--r--recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/make381.patch27
3 files changed, 139 insertions, 0 deletions
diff --git a/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/aticore-2.6.patch b/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/aticore-2.6.patch
new file mode 100644
index 0000000000..44b06c32ce
--- /dev/null
+++ b/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/aticore-2.6.patch
@@ -0,0 +1,82 @@
+diff -U3 -N AtiCore-1.0.1.orig/Makefile AtiCore-1.0.1/Makefile
+--- AtiCore-1.0.1.orig/Makefile 2005-04-05 09:39:23.926196896 +0000
++++ AtiCore-1.0.1/Makefile 2005-04-05 09:58:18.009789984 +0000
+@@ -25,11 +25,13 @@
+ LD = armv5tel-linux-ld
+ endif
+
+-ifndef $(ASFLAGS)
++ifeq "$(FPU)" "soft"
++ASFLAGS=-mfpu=softfpa -mcpu=xscale
++else
+ ASFLAGS=-mcpu=xscale
+ endif
+
+-OBJS = aticore_0.o
++OBJS = aticore_0.o map.o
+ OBJS += aticore_1.o aticore_2.o aticore_3.o aticore_4.o aticore_5.o aticore_6.o aticore_7.o aticore_8.o aticore_9.o
+ # aticore_10.o
+ OBJS += aticore_11.o aticore_12.o aticore_13.o aticore_14.o aticore_15.o aticore_16.o aticore_17.o aticore_18.o aticore_19.o aticore_20.o
+diff -U3 -N AtiCore-1.0.1.orig/aticore_1.s AtiCore-1.0.1/aticore_1.s
+--- AtiCore-1.0.1.orig/aticore_1.s 2005-04-05 09:39:23.928196592 +0000
++++ AtiCore-1.0.1/aticore_1.s 2005-04-05 10:05:35.745244080 +0000
+@@ -282,21 +282,6 @@
+ LDMDB R11, {R4,R11,SP,PC}
+
+ ;;;;;
+- .GLOBAL MapBar
+- .type MapBar, %function
+-MapBar:
+- MOV R12, SP
+- STMFD SP!, {R11,R12,LR,PC}
+- SUB R11, R12, #4
+- MOV R0, #0xF1000000
+- LDR R3, =unk_41948C
+- SUB SP, SP, #0x44
+- STR R0, [R3]
+- B .loc_34D228
+-.loc_34D228:
+- LDMDB R11, {R11,SP,PC}
+-
+-;;;;;
+ .GLOBAL UnMapBar
+ .type UnMapBar, %function
+ UnMapBar:
+diff -U3 -N AtiCore-1.0.1.orig/map.c AtiCore-1.0.1/map.c
+--- AtiCore-1.0.1.orig/map.c 1970-01-01 00:00:00.000000000 +0000
++++ AtiCore-1.0.1/map.c 2005-04-05 09:43:15.469996888 +0000
+@@ -0,0 +1,34 @@
++#include <fcntl.h>
++#include <sys/mman.h>
++#include <unistd.h>
++#include <stdio.h>
++#include <sys/types.h>
++
++extern void *unk_41948C;
++
++void * MapBar(int Dev_Handle, int rp_unk1)
++{
++ int fd;
++ void *ptr;
++
++ fd = open ("/dev/mem", O_RDWR | O_SYNC);
++ if (fd < 0)
++ {
++ perror ("/dev/mem");
++ exit (1);
++ }
++
++ ptr = mmap (NULL, 0x01000000, PROT_READ | PROT_WRITE, MAP_SHARED, fd, 0x08000000);
++ if (ptr == NULL)
++ {
++ perror ("mmap");
++ exit (1);
++ }
++
++ printf("MapBar: %p\n",ptr);
++
++ unk_41948C = ptr;
++
++ return ptr;
++}
++
diff --git a/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/fixstretchblit.patch b/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/fixstretchblit.patch
new file mode 100644
index 0000000000..a89ab3247a
--- /dev/null
+++ b/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/fixstretchblit.patch
@@ -0,0 +1,30 @@
+Index: AtiCore-1.0.1/aticore_2.s
+===================================================================
+--- AtiCore-1.0.1.orig/aticore_2.s 2004-08-28 09:04:06.000000000 +0100
++++ AtiCore-1.0.1/aticore_2.s 2005-07-04 21:56:48.000000000 +0100
+@@ -576,8 +576,6 @@
+ LDR R3, [R11,#-0x2C]
+ STR R3, [R2,#0x24C]
+ B .loc_34DA00
+-unk_432B14: .WORD 0
+-unk_432B10: .WORD 0
+ .loc_34D9F0:
+ MOV R2, #1
+ LDR R1, =0x1284
+Index: AtiCore-1.0.1/aticore_0.s
+===================================================================
+--- AtiCore-1.0.1.orig/aticore_0.s 2004-08-28 08:47:01.000000000 +0100
++++ AtiCore-1.0.1/aticore_0.s 2005-07-04 22:28:55.000000000 +0100
+@@ -14,6 +14,12 @@
+ .GLOBAL unk_41948C
+ unk_41948C: .WORD 0
+ .ALIGN 4
++ .GLOBAL unk_432B14
++unk_432B14: .WORD 0
++ .ALIGN 4
++ .GLOBAL unk_432B10
++unk_432B10: .WORD 0
++ .ALIGN 4
+ .GLOBAL aErrSomeoneCall
+ aErrSomeoneCall: .ASCII "Err:: someone called QL_Bar_Read!\000"
+ .ALIGN 4
diff --git a/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/make381.patch b/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/make381.patch
new file mode 100644
index 0000000000..7aafb7fbf2
--- /dev/null
+++ b/recipes/sharp-binary-only/sharp-aticore-oss-1.0.1/make381.patch
@@ -0,0 +1,27 @@
+Index: AtiCore-1.0.1/Makefile
+===================================================================
+--- AtiCore-1.0.1.orig/Makefile 2006-03-16 12:58:58.000000000 +0100
++++ AtiCore-1.0.1/Makefile 2006-03-16 13:06:00.000000000 +0100
+@@ -9,22 +9,6 @@
+
+ all: $(TARGETSHAREDLIB) testcore atitest
+
+-ifndef $(CC)
+-CC = armv5tel-linux-gcc
+-endif
+-ifndef $(AS)
+-AS = armv5tel-linux-as
+-endif
+-ifndef $(AR)
+-AR = armv5tel-linux-ar
+-endif
+-ifndef $(RANLIB)
+-RANLIB = armv5tel-linux-ranlib
+-endif
+-ifndef $(LD)
+-LD = armv5tel-linux-ld
+-endif
+-
+ ifeq "$(FPU)" "soft"
+ ASFLAGS=-mfpu=softfpa -mcpu=xscale
+ else