aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shfs/shfs-utils_0.35.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/shfs/shfs-utils_0.35.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/shfs/shfs-utils_0.35.bb')
-rw-r--r--recipes/shfs/shfs-utils_0.35.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/shfs/shfs-utils_0.35.bb b/recipes/shfs/shfs-utils_0.35.bb
new file mode 100644
index 0000000000..8c7e05c0e5
--- /dev/null
+++ b/recipes/shfs/shfs-utils_0.35.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
+It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "shfs-modules (${PV})"
+DEPENDS = "virtual/kernel"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
+S = "${WORKDIR}/shfs-${PV}/shfsmount"
+
+KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
+KV = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')[:3]}"
+
+CFLAGS_append=' -DVERSION=\\"${KERNEL_VERSION}\\" -DSHFS_VERSION=\\"${PV}\\" -I../shfs/Linux-${KV}'
+
+do_compile() {
+ oe_runmake LINKER="${CC}"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 shfsmount shfsumount ${D}${bindir}
+}