aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shopper
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/shopper
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/shopper')
-rw-r--r--recipes/shopper/shopper-1.2.1/gcc3.patch11
-rw-r--r--recipes/shopper/shopper-1.2.1/path_fix.patch23
-rw-r--r--recipes/shopper/shopper_1.2.1.bb36
3 files changed, 70 insertions, 0 deletions
diff --git a/recipes/shopper/shopper-1.2.1/gcc3.patch b/recipes/shopper/shopper-1.2.1/gcc3.patch
new file mode 100644
index 0000000000..940b4ea93a
--- /dev/null
+++ b/recipes/shopper/shopper-1.2.1/gcc3.patch
@@ -0,0 +1,11 @@
+--- Shopper/shoppingitem.h.orig 2004-03-07 12:02:51.087057272 +0000
++++ Shopper/shoppingitem.h 2004-03-07 12:03:09.285290720 +0000
+@@ -33,7 +33,7 @@
+
+ public:
+ ShoppingItemCheckBox (const QString & text, QWidget * parent,
+- const char * name=0 );
++ const char * name );
+ signals:
+ void edit();
+
diff --git a/recipes/shopper/shopper-1.2.1/path_fix.patch b/recipes/shopper/shopper-1.2.1/path_fix.patch
new file mode 100644
index 0000000000..d8142c7b22
--- /dev/null
+++ b/recipes/shopper/shopper-1.2.1/path_fix.patch
@@ -0,0 +1,23 @@
+--- Shopper/shoplist.cpp 2008-11-17 21:09:26.000000000 +0000
++++ Shopper/shoplist.cpp 2008-11-17 22:21:12.000000000 +0000
+@@ -38,6 +38,7 @@
+ #include <qmessagebox.h>
+ #include <qregexp.h>
+
++#include <stdlib.h>
+
+ // TODO: Somewhere it should say:
+ // if (mode == ShoppingItem::Left && nothing_left) {
+@@ -229,6 +230,12 @@
+ QString fileName = Global::applicationFileName("ShoppingListQt", "shoppinglist.xml");
+
+ QFile file( fileName );
++ if ( ! file.exists() ) {
++ // Ugly hack
++ QString cmd = QString("cp " SHOPPER_DATADIR "/shoppinglist.xml ") + fileName;
++ system(cmd);
++ }
++
+ _startCategory = static_cast<CategoryItem*>(_showAllAction);
+ // If there's a file - read it. If not then we drop through to do
+ // other initialisation.
diff --git a/recipes/shopper/shopper_1.2.1.bb b/recipes/shopper/shopper_1.2.1.bb
new file mode 100644
index 0000000000..d84af43877
--- /dev/null
+++ b/recipes/shopper/shopper_1.2.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Shopping list manager"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/zaurus-shopper/Shopper-${PV}.tar.gz \
+ file://gcc3.patch;patch=1 \
+ file://path_fix.patch;patch=1"
+S = "${WORKDIR}/Shopper"
+
+inherit palmtop
+
+SHOPPER_DATADIR = "${palmtopdir}/share/shopper"
+CXXFLAGS_append += " -DSHOPPER_DATADIR='"${SHOPPER_DATADIR}"' "
+
+QMAKE_PROFILES = "Shopper.pro"
+
+pkg_postinst() {
+ /opt/QtPalmtop/bin/qcop QPE/System "linkChanged(QString)" 2>/dev/null
+ if [ -n "$D" ]; then false; fi
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/help/html \
+ ${D}${SHOPPER_DATADIR}
+ install -m 0755 ${S}/Shopper ${D}${palmtopdir}/bin/
+ install -m 0644 ${S}/Shopper.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${S}/Shopper.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}/Shopper.html ${D}${palmtopdir}/help/html/
+ install -m 0644 ${S}/shoppinglist.xml ${D}${SHOPPER_DATADIR}/shoppinglist.xml
+}