aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/e-wm-theme-illume-neo_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-15 19:27:26 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-15 19:55:58 +0100
commitf3a637b546878789dcef4d1a3c78a18c765e7ae2 (patch)
tree5a878706c9e00aa617402cd7d6d1e0b9aef31ed7 /recipes/shr/e-wm-theme-illume-neo_git.bb
parent0c8459574b08a9e773c1e7e79c182fe779d04e15 (diff)
downloadopenembedded-f3a637b546878789dcef4d1a3c78a18c765e7ae2.tar.gz
shr themes: new recipes from shr/merge
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/shr/e-wm-theme-illume-neo_git.bb')
-rw-r--r--recipes/shr/e-wm-theme-illume-neo_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/shr/e-wm-theme-illume-neo_git.bb b/recipes/shr/e-wm-theme-illume-neo_git.bb
new file mode 100644
index 0000000000..10a5016758
--- /dev/null
+++ b/recipes/shr/e-wm-theme-illume-neo_git.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "nEo illume theme - a very fast, high contrast illume theme"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RDEPENDS = "e-wm"
+RRECOMMENDS = "elementary-theme-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo etk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENCE = "unknown"
+
+PV = "0.1-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/neo.edc -o ${S}/neo.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/neo.edj ${D}${datadir}/enlightenment/data/themes/
+}
+
+FILES_${PN} = "${datadir}/enlightenment/data/themes/"
+
+pkg_postinst() {
+ echo "To activate this theme make sure to set your enlightenment rendering engine to SOFTWARE or enlightenment will segfault."
+ echo "This theme also ships with an enlightenment bootscreen which can be activated by selecting it under STARTUP in the LOOK tab of enlightenment settings"
+ echo "After activating this theme be sure to switch to SOFTWARE_16 engine in enlightenment advanced settings to unleash the theme's full power ;-)"
+}