aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/elementary-theme-sixteen_git.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 19:05:23 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 19:05:23 +0000
commitd56ffbe90a9e19915f7bbe1de559438946daa916 (patch)
tree54df525c469cf8c8934b6be06ac475b09570fa32 /recipes/shr/elementary-theme-sixteen_git.bb
parentdd9df493e158e09f9379d8232678f7616cbca762 (diff)
downloadopenembedded-d56ffbe90a9e19915f7bbe1de559438946daa916.tar.gz
elementary-theme-*: Elementary themes (from SHR)
Diffstat (limited to 'recipes/shr/elementary-theme-sixteen_git.bb')
-rw-r--r--recipes/shr/elementary-theme-sixteen_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/shr/elementary-theme-sixteen_git.bb b/recipes/shr/elementary-theme-sixteen_git.bb
new file mode 100644
index 0000000000..48cbc615fa
--- /dev/null
+++ b/recipes/shr/elementary-theme-sixteen_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "elementary SHR theme"
+SECTION = "e/utils"
+DEPENDS = "edje-native"
+LICENSE = "MIT BSD"
+PV = "0.1-${EFL_SRCREV}-gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/elementary/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images/. -fd ${S}/fonts/. ${S}/sixteen.edc -o ${S}/sixteen.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/sixteen.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/sixteen.edj"
+
+