aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-15 19:27:26 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-15 19:55:58 +0100
commitf3a637b546878789dcef4d1a3c78a18c765e7ae2 (patch)
tree5a878706c9e00aa617402cd7d6d1e0b9aef31ed7 /recipes/shr
parent0c8459574b08a9e773c1e7e79c182fe779d04e15 (diff)
downloadopenembedded-f3a637b546878789dcef4d1a3c78a18c765e7ae2.tar.gz
shr themes: new recipes from shr/merge
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/e-wm-theme-illume-gry_git.bb25
-rw-r--r--recipes/shr/e-wm-theme-illume-neo_git.bb32
-rw-r--r--recipes/shr/elementary-theme-gry_git.bb26
-rw-r--r--recipes/shr/elementary-theme-neo_git.bb26
-rw-r--r--recipes/shr/etk-theme-neo_git.bb12
-rw-r--r--recipes/shr/etk-theme.inc34
-rw-r--r--recipes/shr/gtk-theme-neo_git.bb15
-rw-r--r--recipes/shr/gtk-theme.inc33
-rw-r--r--recipes/shr/gtk-theme/gtkrc.gtk-theme-neo3
-rw-r--r--recipes/shr/gtk-theme/gtkrc.shr-theme-gtk-e17lookalike3
-rw-r--r--recipes/shr/icon-theme-neo_git.bb27
-rw-r--r--recipes/shr/libframeworkd-phonegui-efl-theme-neo_git.bb26
-rw-r--r--recipes/shr/libframeworkd-phonegui-efl-theme.inc22
-rw-r--r--recipes/shr/shr-splash-theme-logo_git.bb13
-rw-r--r--recipes/shr/shr-splash-theme-tux_git.bb11
-rw-r--r--recipes/shr/shr-theme-gry.bb7
-rw-r--r--recipes/shr/shr-theme-gtk-e17lookalike_git.bb10
-rw-r--r--recipes/shr/shr-theme-neo.bb11
-rw-r--r--recipes/shr/shr-theme-sixteen.bb7
19 files changed, 343 insertions, 0 deletions
diff --git a/recipes/shr/e-wm-theme-illume-gry_git.bb b/recipes/shr/e-wm-theme-illume-gry_git.bb
new file mode 100644
index 0000000000..e993cb6e37
--- /dev/null
+++ b/recipes/shr/e-wm-theme-illume-gry_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "gry* illume theme - a fast, shiny illume theme"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RRECOMMENDS = "elementary-theme-gry"
+LICENCE = "unknown"
+
+PV = "0.3-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/gry.edc -o ${S}/gry.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/gry.edj ${D}${datadir}/enlightenment/data/themes/
+}
+
+FILES_${PN} = "${datadir}/enlightenment/data/themes/"
diff --git a/recipes/shr/e-wm-theme-illume-neo_git.bb b/recipes/shr/e-wm-theme-illume-neo_git.bb
new file mode 100644
index 0000000000..10a5016758
--- /dev/null
+++ b/recipes/shr/e-wm-theme-illume-neo_git.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "nEo illume theme - a very fast, high contrast illume theme"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RDEPENDS = "e-wm"
+RRECOMMENDS = "elementary-theme-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo etk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENCE = "unknown"
+
+PV = "0.1-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/neo.edc -o ${S}/neo.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/neo.edj ${D}${datadir}/enlightenment/data/themes/
+}
+
+FILES_${PN} = "${datadir}/enlightenment/data/themes/"
+
+pkg_postinst() {
+ echo "To activate this theme make sure to set your enlightenment rendering engine to SOFTWARE or enlightenment will segfault."
+ echo "This theme also ships with an enlightenment bootscreen which can be activated by selecting it under STARTUP in the LOOK tab of enlightenment settings"
+ echo "After activating this theme be sure to switch to SOFTWARE_16 engine in enlightenment advanced settings to unleash the theme's full power ;-)"
+}
diff --git a/recipes/shr/elementary-theme-gry_git.bb b/recipes/shr/elementary-theme-gry_git.bb
new file mode 100644
index 0000000000..2b1dfaab3c
--- /dev/null
+++ b/recipes/shr/elementary-theme-gry_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "gry* elementary theme - a fast, shiny elementary theme"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RRECOMMENDS = "e-wm-theme-illume-gry"
+LICENSE = "unknown"
+
+PV = "0.8-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master \
+ "
+
+S = "${WORKDIR}/git/elementary/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/gry.edc -o ${S}/gry.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/gry.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/"
diff --git a/recipes/shr/elementary-theme-neo_git.bb b/recipes/shr/elementary-theme-neo_git.bb
new file mode 100644
index 0000000000..4701c220c6
--- /dev/null
+++ b/recipes/shr/elementary-theme-neo_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "nEo elementary theme - a very fast, high contrast etk theme"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RRECOMMENDS = "e-wm-theme-illume-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo etk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2.1-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r3"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master \
+ "
+
+S = "${WORKDIR}/git/elementary/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/neo.edc -o ${S}/neo.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/neo.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/"
diff --git a/recipes/shr/etk-theme-neo_git.bb b/recipes/shr/etk-theme-neo_git.bb
new file mode 100644
index 0000000000..2c68bd29da
--- /dev/null
+++ b/recipes/shr/etk-theme-neo_git.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "nEo etk theme - a very fast, high contrast etk theme"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RRECOMMENDS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+require etk-theme.inc
diff --git a/recipes/shr/etk-theme.inc b/recipes/shr/etk-theme.inc
new file mode 100644
index 0000000000..6e8b33db27
--- /dev/null
+++ b/recipes/shr/etk-theme.inc
@@ -0,0 +1,34 @@
+SECTION = "e/utils"
+DEPENDS = "edje-native"
+RDEPENDS = "etk"
+
+S = "${WORKDIR}/git/etk/${PN}/"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/default.edc -o ${S}/default.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/etk/themes.${PN}/
+ install -m 0644 ${S}/default.edj ${D}${datadir}/etk/themes.${PN}/
+}
+
+FILES_${PN} = "${datadir}/etk/themes.${PN}"
+
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "etk-theme"
+ALTERNATIVE_LINK = "${datadir}/etk/themes"
+ALTERNATIVE_PATH = "${datadir}/etk/themes.${PN}"
+ALTERNATIVE_PRIORITY ?= 1
+
+pkg_postinst() {
+ if [[ -e ${ALTERNATIVE_LINK} && ! -h ${ALTERNATIVE_LINK} ]] ; then
+ echo "warn: ${ALTERNATIVE_LINK} exists and it's not a link!"
+ echo "warn: It will be replaced with link managed by update-alternatives"
+ echo "warn: Moving ${ALTERNATIVE_LINK} to ${ALTERNATIVE_LINK}.old."
+ echo "warn: It should be empty but probably isn't!"
+ echo "warn: Check what's left there and remove it manually."
+ mv -f ${ALTERNATIVE_LINK} ${ALTERNATIVE_LINK}.old
+ fi
+}
diff --git a/recipes/shr/gtk-theme-neo_git.bb b/recipes/shr/gtk-theme-neo_git.bb
new file mode 100644
index 0000000000..66caabf1cc
--- /dev/null
+++ b/recipes/shr/gtk-theme-neo_git.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "nEo GTK theme - a very fast, high contrast GTK theme"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS += "icon-theme-neo"
+RRECOMMENDS = "elementary-theme-neo e-wm-theme-illume-neo libframeworkd-phonegui-efl-theme-neo etk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r3"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/gtk/${PN}/"
+
+require gtk-theme.inc
diff --git a/recipes/shr/gtk-theme.inc b/recipes/shr/gtk-theme.inc
new file mode 100644
index 0000000000..449d0e0b28
--- /dev/null
+++ b/recipes/shr/gtk-theme.inc
@@ -0,0 +1,33 @@
+RPROVIDES_${PN} += "virtual/theme-gtk"
+RDEPENDS = "gtk+"
+SECTION = "gtk"
+
+inherit update-alternatives
+
+SRC_URI += "file://gtk-theme/gtkrc.${PN}"
+
+do_install() {
+ install -d "${D}${datadir}/themes/${PN}/gtk-2.0"
+ cp -r "${S}/./" "${D}${datadir}/themes/${PN}/gtk-2.0"
+ install -d ${D}${sysconfdir}/gtk-2.0/
+ install -m 0644 ${WORKDIR}/gtk-theme/gtkrc.${PN} ${D}${sysconfdir}/gtk-2.0/gtkrc.${PN}
+}
+
+FILES_${PN} = "${datadir}/themes/${PN}/ \
+ ${sysconfdir}/gtk-2.0/gtkrc.${PN} \
+ "
+
+ALTERNATIVE_NAME = "gtk-theme"
+ALTERNATIVE_LINK = "${sysconfdir}/gtk-2.0/gtkrc"
+ALTERNATIVE_PATH = "${sysconfdir}/gtk-2.0/gtkrc.${PN}"
+
+pkg_postinst() {
+ if [[ -e ${ALTERNATIVE_LINK} && ! -h ${ALTERNATIVE_LINK} ]] ; then
+ echo "warn: ${ALTERNATIVE_LINK} exists and it's not a link!"
+ echo "warn: It will be replaced with link managed by update-alternatives"
+ echo "warn: Moving ${ALTERNATIVE_LINK} to ${ALTERNATIVE_LINK}.old."
+ echo "warn: It should be empty but probably isn't!"
+ echo "warn: Check what's left there and remove it manually."
+ mv -f ${ALTERNATIVE_LINK} ${ALTERNATIVE_LINK}.old
+ fi
+}
diff --git a/recipes/shr/gtk-theme/gtkrc.gtk-theme-neo b/recipes/shr/gtk-theme/gtkrc.gtk-theme-neo
new file mode 100644
index 0000000000..c27c4c44a2
--- /dev/null
+++ b/recipes/shr/gtk-theme/gtkrc.gtk-theme-neo
@@ -0,0 +1,3 @@
+gtk-font-name = "Sans 5"
+gtk-theme-name = "gtk-theme-neo"
+gtk-icon-theme-name = "nEo"
diff --git a/recipes/shr/gtk-theme/gtkrc.shr-theme-gtk-e17lookalike b/recipes/shr/gtk-theme/gtkrc.shr-theme-gtk-e17lookalike
new file mode 100644
index 0000000000..c63cd733fb
--- /dev/null
+++ b/recipes/shr/gtk-theme/gtkrc.shr-theme-gtk-e17lookalike
@@ -0,0 +1,3 @@
+gtk-font-name = "Sans 5"
+gtk-theme-name = "shr-theme-gtk-e17lookalike"
+gtk-icon-theme-name = "openmoko-standard"
diff --git a/recipes/shr/icon-theme-neo_git.bb b/recipes/shr/icon-theme-neo_git.bb
new file mode 100644
index 0000000000..438ac238c9
--- /dev/null
+++ b/recipes/shr/icon-theme-neo_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "nEo icon theme - a high contrast icon theme which looks especially well when using all the other nEo themes"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "e-wm"
+RRECOMMENDS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo etk-theme-neo gpe-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/icons/icon-theme-neo"
+
+do_install() {
+ install -d ${D}${datadir}/icons/
+ install -d ${D}${datadir}/icons/nEo/
+ cp -r ${S}/* "${D}${datadir}/icons/nEo/"
+}
+
+FILES_${PN} = "${datadir}/icons/nEo/"
+
+pkg_postinst() {
+ echo "To activate this theme select it under ICON THEME in the LOOK tab of enlightenment settings"
+ echo "Restart enlightenment for the changes to take affect"
+}
diff --git a/recipes/shr/libframeworkd-phonegui-efl-theme-neo_git.bb b/recipes/shr/libframeworkd-phonegui-efl-theme-neo_git.bb
new file mode 100644
index 0000000000..7f7f6b4fe1
--- /dev/null
+++ b/recipes/shr/libframeworkd-phonegui-efl-theme-neo_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "nEo libframeworkd-phonegui-efl - a very fast, high contrast etk theme"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "libframeworkd-phonegui-efl"
+RRECOMMENDS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo etk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r2"
+
+require libframeworkd-phonegui-efl-theme.inc
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/libframeworkd-phonegui-efl/theme-neo"
+
+do_compile() {
+ for edc in call contacts dialer dialog elm-resizing-label incoming-message keypad messages sim-auth ussd ; do
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/${edc}/. -fd ${S}/${edc}. ${S}/${edc}/${edc}.edc -o ${S}/${edc}.edj
+ done
+}
+
+do_install() {
+ install -d ${D}${datadir}/libframeworkd-phonegui-efl.${PN}/
+ install -m 0644 ${S}/*.edj ${D}${datadir}/libframeworkd-phonegui-efl.${PN}/
+}
diff --git a/recipes/shr/libframeworkd-phonegui-efl-theme.inc b/recipes/shr/libframeworkd-phonegui-efl-theme.inc
new file mode 100644
index 0000000000..eab118f322
--- /dev/null
+++ b/recipes/shr/libframeworkd-phonegui-efl-theme.inc
@@ -0,0 +1,22 @@
+SECTION = "e/utils"
+DEPENDS += "edje-native"
+
+FILES_${PN} += "${datadir}/libframeworkd-phonegui-efl.${PN}"
+
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "libframeworkd-phonegui-efl-theme"
+ALTERNATIVE_LINK = "${datadir}/libframeworkd-phonegui-efl"
+ALTERNATIVE_PATH = "${datadir}/libframeworkd-phonegui-efl.${PN}"
+ALTERNATIVE_PRIORITY ?= 1
+
+pkg_postinst() {
+ if [[ -e ${ALTERNATIVE_LINK} && ! -h ${ALTERNATIVE_LINK} ]] ; then
+ echo "warn: ${ALTERNATIVE_LINK} exists and it's not a link!"
+ echo "warn: It will be replaced with link managed by update-alternatives"
+ echo "warn: Moving ${ALTERNATIVE_LINK} to ${ALTERNATIVE_LINK}.old."
+ echo "warn: It should be empty but probably isn't!"
+ echo "warn: Check what's left there and remove it manually."
+ mv -f ${ALTERNATIVE_LINK} ${ALTERNATIVE_LINK}.old
+ fi
+}
diff --git a/recipes/shr/shr-splash-theme-logo_git.bb b/recipes/shr/shr-splash-theme-logo_git.bb
new file mode 100644
index 0000000000..09ea014e79
--- /dev/null
+++ b/recipes/shr/shr-splash-theme-logo_git.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "SHR splash screen - SHR logo theme"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "0.1+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/shr-splash/${PN}"
+
+ALTERNATIVE_PRIORITY = 3
+
+require shr-splash-theme.inc
+
diff --git a/recipes/shr/shr-splash-theme-tux_git.bb b/recipes/shr/shr-splash-theme-tux_git.bb
new file mode 100644
index 0000000000..743dacd2b4
--- /dev/null
+++ b/recipes/shr/shr-splash-theme-tux_git.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "SHR splash screen - SHR Tux theme"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "0.1+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/shr-splash/${PN}"
+
+require shr-splash-theme.inc
+
diff --git a/recipes/shr/shr-theme-gry.bb b/recipes/shr/shr-theme-gry.bb
new file mode 100644
index 0000000000..7a2e6e1728
--- /dev/null
+++ b/recipes/shr/shr-theme-gry.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "gry* - a fast, shiny theme"
+SECTION = "x11/data"
+RDEPENDS += "e-wm-theme-illume-gry elementary-theme-gry"
+PV = "0.1"
+PR = "r1"
+
+ALLOW_EMPTY = "1"
diff --git a/recipes/shr/shr-theme-gtk-e17lookalike_git.bb b/recipes/shr/shr-theme-gtk-e17lookalike_git.bb
new file mode 100644
index 0000000000..04ab37dc63
--- /dev/null
+++ b/recipes/shr/shr-theme-gtk-e17lookalike_git.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "A gtk theme that looks like e17"
+LICENSE = "MIT BSD"
+PV = "0.1.1+gitr${SRCPV}"
+PR = "r5"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/gtk/${PN}"
+
+require gtk-theme.inc
diff --git a/recipes/shr/shr-theme-neo.bb b/recipes/shr/shr-theme-neo.bb
new file mode 100644
index 0000000000..20186ffe31
--- /dev/null
+++ b/recipes/shr/shr-theme-neo.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "nEo shr theme - a very fast, high contrast shr theme"
+SECTION = "x11/data"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2"
+PR = "r1"
+
+ALLOW_EMPTY = "1"
diff --git a/recipes/shr/shr-theme-sixteen.bb b/recipes/shr/shr-theme-sixteen.bb
new file mode 100644
index 0000000000..d7b789239d
--- /dev/null
+++ b/recipes/shr/shr-theme-sixteen.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "Sixteen SHR theme"
+SECTION = "x11/data"
+RDEPENDS += "e-wm-theme-illume-sixteen elementary-theme-sixteen"
+PV = "0.1"
+PR = "r1"
+
+ALLOW_EMPTY = "1"