aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-01-15 12:56:59 +0100
committerSimon Busch <morphis@amethyst.openembedded.net>2011-01-15 13:02:24 +0100
commite401549bd493dd5ac05b9ce5f809f84c177dfe5e (patch)
tree922c0d07facffb3b9fb0476ce0ff364e0c872fcc /recipes/shr
parent7cb94837953f7308714efd8a0ebf2bdff4f49f75 (diff)
downloadopenembedded-e401549bd493dd5ac05b9ce5f809f84c177dfe5e.tar.gz
initscripts-shr: add modified version of halt/reboot scripts for palmpre machine
Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/initscripts-shr/palmpre/halt25
-rw-r--r--recipes/shr/initscripts-shr/palmpre/reboot11
-rw-r--r--recipes/shr/initscripts-shr_0.0.1.bb2
3 files changed, 37 insertions, 1 deletions
diff --git a/recipes/shr/initscripts-shr/palmpre/halt b/recipes/shr/initscripts-shr/palmpre/halt
new file mode 100644
index 0000000000..6b3dc0d8ed
--- /dev/null
+++ b/recipes/shr/initscripts-shr/palmpre/halt
@@ -0,0 +1,25 @@
+#! /bin/sh
+#
+# halt Execute the halt command.
+#
+# Version: @(#)halt 2.84-2 07-Jan-2002 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# See if we need to cut the power.
+if test -x /etc/init.d/ups-monitor
+then
+ /etc/init.d/ups-monitor poweroff
+fi
+
+# Don't shut down drives if we're using RAID.
+hddown="-h"
+if grep -qs '^md.*active' /proc/mdstat
+then
+ hddown=""
+fi
+
+/sbin/tellbootie shutdown
+
+: exit 0
diff --git a/recipes/shr/initscripts-shr/palmpre/reboot b/recipes/shr/initscripts-shr/palmpre/reboot
new file mode 100644
index 0000000000..195f540d2f
--- /dev/null
+++ b/recipes/shr/initscripts-shr/palmpre/reboot
@@ -0,0 +1,11 @@
+#! /bin/sh
+#
+# reboot Execute the reboot command.
+#
+# Version: @(#)reboot 2.75 22-Jun-1998 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+echo -n "Rebooting... "
+/sbin/tellbootie
diff --git a/recipes/shr/initscripts-shr_0.0.1.bb b/recipes/shr/initscripts-shr_0.0.1.bb
index 397cff769d..88f89e193e 100644
--- a/recipes/shr/initscripts-shr_0.0.1.bb
+++ b/recipes/shr/initscripts-shr_0.0.1.bb
@@ -5,7 +5,7 @@ DEPENDS = ""
RDEPENDS_${PN} = "procps"
LICENSE = "GPL"
PV = "0.0.1"
-PR = "r21"
+PR = "r22"
RCONFLICTS_${PN} = "initscripts"