aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sip
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2010-09-05 21:28:32 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-27 17:03:51 -0700
commit37bf830772ff666b51cb38687323c353ac0e75ee (patch)
tree6cdcebfbd7d02522fefb0a4399e60c52591520be /recipes/sip
parent6e15655f69d34cdb727f8b37d707a2b5e818670e (diff)
downloadopenembedded-37bf830772ff666b51cb38687323c353ac0e75ee.tar.gz
sip-native: Convert to new style staging, remove do_stage()
* Convert do_stage to do_install * Inherit recipe with python-dir for PYTHON_SITEPACKAGES_DIR variable * Replace ${STAGING_BINDIR_NATIVE} with ${D}${bindir} * Replace ${STAGING_PYDIR}/site-packages with ${D}${PYTHON_SITEPACKAGES_DIR} * Set NATIVE_INSTALL_WORKS = "1" * Bump PR from "ml0" to "ml1" Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/sip')
-rw-r--r--recipes/sip/sip-native_4.7.9.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes/sip/sip-native_4.7.9.bb b/recipes/sip/sip-native_4.7.9.bb
index 106c81e39e..09d9056156 100644
--- a/recipes/sip/sip-native_4.7.9.bb
+++ b/recipes/sip/sip-native_4.7.9.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "ml0"
+PR = "ml1"
SRC_URI = "http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-${PV}.tar.gz"
SRC_URI[md5sum] = "597d7ff7edb42a18421c806ffd18a136"
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "7faaccb6f17296399051bd076a7f41e0f6d95a28eda3e30468f1bd7cf4
S = "${WORKDIR}/sip-${PV}/sipgen"
-inherit qt4x11 native
+inherit qt4x11 native python-dir
EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
@@ -24,12 +24,13 @@ export STAGING_INCDIR
do_configure_prepend() {
cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
}
-do_stage() {
- install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 sip ${D}${bindir}/sip
cd ${WORKDIR}/sip-${PV} && python configure.py
- install -d ${STAGING_PYDIR}/site-packages
- install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ install -m 0755 sip*.py ${D}${PYTHON_SITEPACKAGES_DIR}
}
DEFAULT_PREFERENCE = "-1"
-
+NATIVE_INSTALL_WORKS = "1"