aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/skippy/skippy-xd_0.5.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/skippy/skippy-xd_0.5.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/skippy/skippy-xd_0.5.0.bb')
-rw-r--r--recipes/skippy/skippy-xd_0.5.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/skippy/skippy-xd_0.5.0.bb b/recipes/skippy/skippy-xd_0.5.0.bb
new file mode 100644
index 0000000000..c5ed177aa6
--- /dev/null
+++ b/recipes/skippy/skippy-xd_0.5.0.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPLV2"
+DESCRIPTION = "Skippy is a full-screen task-switcher for X11."
+SECTION = "x11"
+DEPENDS = "virtual/xserver libxdamage libxcomposite"
+
+inherit pkgconfig
+
+SRC_URI = "http://thegraveyard.org/files/${PN}-${PV}.tar.bz2 \
+ file://fix-makefile.patch;patch=1 \
+ file://event_base.patch;patch=1"
+
+EXTRA_OEMAKE = "X11PREFIX='${STAGING_DIR_TARGET}${layout_prefix}' PKG_CONFIG='${STAGING_BINDIR_NATIVE}/pkg-config'"
+CFLAGS_append = " -I${STAGING_INCDIR}/X11"
+LDFLAGS_append = " -L${STAGING_LIBDIR}/X11"
+
+do_install() {
+ oe_runmake 'BINDIR=${D}${bindir}' install
+}