aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/slrn
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/slrn
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/slrn')
-rw-r--r--recipes/slrn/slrn-0.9.8.0/chkslang.patch16
-rw-r--r--recipes/slrn/slrn-0.9.8.0/m4.patch31
-rw-r--r--recipes/slrn/slrn_0.9.8.0.bb16
3 files changed, 63 insertions, 0 deletions
diff --git a/recipes/slrn/slrn-0.9.8.0/chkslang.patch b/recipes/slrn/slrn-0.9.8.0/chkslang.patch
new file mode 100644
index 0000000000..8ee09652a3
--- /dev/null
+++ b/recipes/slrn/slrn-0.9.8.0/chkslang.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- slrn-0.9.8.0/src/Makefile.am~chkslang 2003-07-29 16:10:41.000000000 -0400
++++ slrn-0.9.8.0/src/Makefile.am 2004-03-05 16:52:23.000000000 -0500
+@@ -37,7 +37,7 @@
+ ## This is a hack
+ slangversion_SOURCES =
+ slangversion$(EXEEXT): chkslang$(EXEEXT)
+- ./chkslang$(EXEEXT) slrn 10003 10400
++# ./chkslang$(EXEEXT) slrn 10003 10400
+
+ ## Another hack: Find out whether slrnpull support gets compiled in
+ stamp2: config.h
diff --git a/recipes/slrn/slrn-0.9.8.0/m4.patch b/recipes/slrn/slrn-0.9.8.0/m4.patch
new file mode 100644
index 0000000000..5fc5db77e7
--- /dev/null
+++ b/recipes/slrn/slrn-0.9.8.0/m4.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null 2003-09-23 18:19:32.000000000 -0400
++++ slrn-0.9.8.0/autoconf/ulonglong.m4 2004-03-05 16:39:20.000000000 -0500
+@@ -0,0 +1,23 @@
++# ulonglong.m4 serial 2 (fileutils-4.0.32, gettext-0.10.40)
++dnl Copyright (C) 1999-2002 Free Software Foundation, Inc.
++dnl This file is free software, distributed under the terms of the GNU
++dnl General Public License. As a special exception to the GNU General
++dnl Public License, this file may be distributed as part of a program
++dnl that contains a configuration script generated by Autoconf, under
++dnl the same distribution terms as the rest of that program.
++
++dnl From Paul Eggert.
++
++AC_DEFUN([jm_AC_TYPE_UNSIGNED_LONG_LONG],
++[
++ AC_CACHE_CHECK([for unsigned long long], ac_cv_type_unsigned_long_long,
++ [AC_TRY_LINK([unsigned long long ull = 1; int i = 63;],
++ [unsigned long long ullmax = (unsigned long long) -1;
++ return ull << i | ull >> i | ullmax / ull | ullmax % ull;],
++ ac_cv_type_unsigned_long_long=yes,
++ ac_cv_type_unsigned_long_long=no)])
++ if test $ac_cv_type_unsigned_long_long = yes; then
++ AC_DEFINE(HAVE_UNSIGNED_LONG_LONG, 1,
++ [Define if you have the unsigned long long type.])
++ fi
++])
diff --git a/recipes/slrn/slrn_0.9.8.0.bb b/recipes/slrn/slrn_0.9.8.0.bb
new file mode 100644
index 0000000000..b491023112
--- /dev/null
+++ b/recipes/slrn/slrn_0.9.8.0.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+DESCRIPTION = "slrn - console news reader"
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "slang"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/slrn/slrn-${PV}.tar.bz2 \
+ file://m4.patch;patch=1 \
+ file://chkslang.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-setgid-code --enable-spool --with-slrnpull \
+ --with-slang-library=${STAGING_LIBDIR} \
+ --with-slang-includes=${STAGING_INCDIR}"