summaryrefslogtreecommitdiffstats
path: root/recipes/slugimage/slugimage.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/slugimage/slugimage.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/slugimage/slugimage.bb')
-rw-r--r--recipes/slugimage/slugimage.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/slugimage/slugimage.bb b/recipes/slugimage/slugimage.bb
new file mode 100644
index 0000000000..67367d5192
--- /dev/null
+++ b/recipes/slugimage/slugimage.bb
@@ -0,0 +1,24 @@
+# slugimage - normally built native, a perl script
+SECTION = "console/utils"
+LICENSE = "BSD"
+DESCRIPTION = "Slugimage is a small app to disassemble and reassemble \
+flash images for the Linksys NSLU2 device. It also has jffs2 support"
+PR = "r12"
+
+RDEPENDS = "perl"
+
+SLUGIMAGE_SVN_REV ?= "104"
+SLUGIMAGE_SVN_REPO ?= "http://svn.nslu2-linux.org/svnroot/slugimage/trunk"
+
+addtask svnfetch before do_configure after do_patch
+
+do_svnfetch() {
+ svn co ${SLUGIMAGE_SVN_REPO} --revision ${SLUGIMAGE_SVN_REV} ${WORKDIR}
+}
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 slugimage ${D}${bindir}/
+}