aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-11-10 13:34:04 -0500
committerMichael Smith <msmith@cbnco.com>2010-11-11 07:47:04 -0500
commit2c41577edaa26a7f09c1727dcc2c9f2758e2deff (patch)
tree6222849473b663a9ce8d7b0af81cf368162dfa6c /recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
parentaf1a2e0e7626e372f22afbcabf08d9ae6b0d7b01 (diff)
downloadopenembedded-2c41577edaa26a7f09c1727dcc2c9f2758e2deff.tar.gz
smpeg: configure with --disable-rpath
Otherwise libtool and ld try to link against ${libdir}/libdl.so.2 on the host system. Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch')
-rw-r--r--recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch b/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
new file mode 100644
index 0000000000..e1de0ea1e8
--- /dev/null
+++ b/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
@@ -0,0 +1,47 @@
+Upstream: http://icculus.org/pipermail/smpeg/2010-November/000183.html
+
+Add --disable-rpath to fix build in OE.
+
+--- trunk/configure.in.orig 2010-11-07 09:00:19.000000000 -0500
++++ trunk/configure.in 2010-11-10 13:02:06.000000000 -0500
+@@ -84,19 +84,27 @@
+ ;;
+ esac
+
+-# Set runtime shared library paths as needed
+-
+-case "$target" in
+- *-*-linux*)
+- SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
+- ;;
+- *-*-freebsd*)
+- SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
+- ;;
+- *-*-solaris*)
+- SMPEG_RLD_FLAGS="-R\${exec_prefix}/lib"
+- ;;
+-esac
++dnl Set runtime shared library paths as needed
++AC_ARG_ENABLE(rpath,
++ AC_HELP_STRING([--enable-rpath],
++ [use an rpath when linking SDL [[default=yes]]]),,
++ enable_rpath=yes)
++
++if test "x$enable_rpath" = "xyes"; then
++ case "$target" in
++ *-*-linux*)
++ SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
++ ;;
++ *-*-freebsd*)
++ SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
++ ;;
++ *-*-solaris*)
++ SMPEG_RLD_FLAGS="-R\${exec_prefix}/lib"
++ ;;
++ esac
++else
++ SMPEG_RLD_FLAGS=""
++fi
+
+ AC_SUBST(SMPEG_RLD_FLAGS)
+