aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sms-sentry
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:12:12 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:34 +0100
commit305be9e66f2c4c3a3420ce7f97a5526566f5934d (patch)
treeb8f0e14abbbf443833f6b92ec5c535a08d035d03 /recipes/sms-sentry
parent27f9b46ed6d939c6977726adab077e448ba6bcd4 (diff)
downloadopenembedded-305be9e66f2c4c3a3420ce7f97a5526566f5934d.tar.gz
sms-sentry: new recipe from SHR
Diffstat (limited to 'recipes/sms-sentry')
-rw-r--r--recipes/sms-sentry/sms-sentry.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/sms-sentry/sms-sentry.bb b/recipes/sms-sentry/sms-sentry.bb
new file mode 100644
index 0000000000..be6c22c831
--- /dev/null
+++ b/recipes/sms-sentry/sms-sentry.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "An SMS monitor to locate a Neo Freerunner"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "python"
+
+PR = "r1"
+
+SRC_URI = "http://www.handheldshell.com/software/fso/sms-sentry_1.01.tgz"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "sms-sentry.sh"
+INITSCRIPT_PARAMS = "defaults 35"
+
+S = ${WORKDIR}/sms-sentry_1.01
+
+do_install() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/default
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/sms-sentry.sh ${D}/${sysconfdir}/init.d/
+ install -m 0755 ${S}/sms-sentry ${D}/usr/bin/
+ install -m 0644 ${S}/sms-sentry.default ${D}/${sysconfdir}/default/sms-sentry.default
+}
+
+do_configure() {
+ exit 0
+}
+
+do_compile() {
+ exit 0
+}
+