aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/snmp++
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/snmp++
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/snmp++')
-rw-r--r--recipes/snmp++/snmp++_3.2.10.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/snmp++/snmp++_3.2.10.bb b/recipes/snmp++/snmp++_3.2.10.bb
new file mode 100644
index 0000000000..43af916aec
--- /dev/null
+++ b/recipes/snmp++/snmp++_3.2.10.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A C++ SNMP library that supports SNMPv1, SNMPv2c and SNMPv3"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libdes libtomcrypt"
+LICENSE = "snmp++"
+SRC_URI = "http://www.agentpp.com/snmp++v${PV}.tar.gz"
+S = "${WORKDIR}/snmp++/src"
+
+CFLAGS_append = " -I../include"
+
+do_compile() {
+ oe_runmake -f Makefile.linux LIBDESDIR=${STAGING_LIBDIR} LIBTOMCRYPTDIR=${STAGING_LIBDIR}
+}
+
+do_stage() {
+ oe_libinstall -a -C ../lib libsnmp++ ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/snmp++
+ install -m 0644 ../include/*.h ${STAGING_INCDIR}/snmp++
+}