aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/softfan
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/softfan
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/softfan')
-rw-r--r--recipes/softfan/softfan_0.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/softfan/softfan_0.10.bb b/recipes/softfan/softfan_0.10.bb
new file mode 100644
index 0000000000..b589d736bf
--- /dev/null
+++ b/recipes/softfan/softfan_0.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Fan controller for fans attached to parallel port"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRC_URI = "http://joshuawise.com/code/softfan/softfan-${PV}.tar.gz"
+S = "${WORKDIR}/softfan-${PV}"
+
+FILES_${PN} = "/sbin/softfan"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o softfan softfan.c
+}
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install -m 0755 softfan ${D}${base_sbindir}/softfan
+}