summaryrefslogtreecommitdiffstats
path: root/recipes/sox/sox_13.0.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-07 11:43:36 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-07 11:43:36 -0700
commitfc909a927ddfcb4c0c10da1b278b496c68319a6a (patch)
tree49ac3580664da0782c428430dfbb6edb611bfd80 /recipes/sox/sox_13.0.0.bb
parentd326c188d3efaf1c66f7bd7af97d4d3c98addb9f (diff)
downloadopenembedded-fc909a927ddfcb4c0c10da1b278b496c68319a6a.tar.gz
sox: Get rid of do_stage and use BBCLASSEXTEND
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/sox/sox_13.0.0.bb')
-rw-r--r--recipes/sox/sox_13.0.0.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes/sox/sox_13.0.0.bb b/recipes/sox/sox_13.0.0.bb
index b2ffbbea0a..3529aa0ef7 100644
--- a/recipes/sox/sox_13.0.0.bb
+++ b/recipes/sox/sox_13.0.0.bb
@@ -1,22 +1,26 @@
DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
It converts audio files among various standard audio file formats \
-and can apply different effects and filters to the audio data."
+and can apply different effects and filters to the audio data."
HOMEPAGE = "http://sox.sourceforge.net"
SECTION = "audio"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz \
file://src-Makefile.am.patch"
+SRC_URI_virtclass-native = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz"
+
inherit autotools
do_install() {
- make bindir="${D}${bindir}" libdir="${D}${libdir}" mandir="${D}/${mandir}" includedir="${D}${includedir}" install
+ make bindir="${D}${bindir}" libdir="${D}${libdir}" mandir="${D}${mandir}" includedir="${D}${includedir}" install
rm ${D}${bindir}/rec
ln -s /usr/bin/play ${D}${bindir}/rec
}
+BBCLASSEXTEND = "native"
+
SRC_URI[md5sum] = "0243d62895caee558b5294d5b78cfbcb"
SRC_URI[sha256sum] = "c66c52cfa42fe126592563c3d8974007a9858bd35d2c1136389a721eeebb9f8e"