aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sox
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sox
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sox')
-rw-r--r--recipes/sox/sox-native_13.0.0.bb19
-rw-r--r--recipes/sox/sox/src-Makefile.am.patch11
-rw-r--r--recipes/sox/sox/uclibc-fixes.patch35
-rw-r--r--recipes/sox/sox_12.17.5.bb20
-rw-r--r--recipes/sox/sox_13.0.0.bb18
5 files changed, 103 insertions, 0 deletions
diff --git a/recipes/sox/sox-native_13.0.0.bb b/recipes/sox/sox-native_13.0.0.bb
new file mode 100644
index 0000000000..9be032260c
--- /dev/null
+++ b/recipes/sox/sox-native_13.0.0.bb
@@ -0,0 +1,19 @@
+include sox_${PV}.bb
+
+S = "${WORKDIR}/sox-${PV}"
+
+inherit native
+
+do_patch() {
+ true
+}
+
+do_stage() {
+ make bindir="${STAGING_BINDIR}" libdir="${STAGING_LIBDIR}" mandir="${STAGING_DIR_HOST}${layout_mandir}" includedir="${STAGING_INCDIR}" install
+ rm ${STAGING_BINDIR}/rec
+ ln -s ${STAGING_BINDIR}/play ${STAGING_BINDIR}/rec
+}
+
+do_install() {
+ true
+}
diff --git a/recipes/sox/sox/src-Makefile.am.patch b/recipes/sox/sox/src-Makefile.am.patch
new file mode 100644
index 0000000000..b5ffd398ae
--- /dev/null
+++ b/recipes/sox/sox/src-Makefile.am.patch
@@ -0,0 +1,11 @@
+--- sox-13.0.0.old/src/Makefile.am 2007-03-18 22:19:52.296535098 -0400
++++ sox-13.0.0/src/Makefile.am 2007-03-18 22:21:48.968947731 -0400
+@@ -42,7 +42,7 @@
+ $(MAKE) -C libgsm
+
+ play rec: sox$(EXEEXT)
+- ./sox --help > /dev/null
++# ./sox --help > /dev/null
+ test -f .libs/lt-sox && ( $(RM) $@ && $(LN_S) .libs/lt-sox $@ ) || $(LN_S) sox$(EXEEXT) $@
+
+ install-exec-hook:
diff --git a/recipes/sox/sox/uclibc-fixes.patch b/recipes/sox/sox/uclibc-fixes.patch
new file mode 100644
index 0000000000..7344d90aa3
--- /dev/null
+++ b/recipes/sox/sox/uclibc-fixes.patch
@@ -0,0 +1,35 @@
+--- sox-12.17.5/vol.c 2001-11-22 20:42:57.000000000 -0700
++++ sox-12.17.5.new/vol.c 2004-09-30 16:42:47.211148824 -0700
+@@ -15,8 +15,8 @@
+ /* type used for computations.
+ */
+ #ifndef VOL_FLOAT
+-#define VOL_FLOAT float
+-#define VOL_FLOAT_SCAN "%f"
++#define VOL_FLOAT double
++#define VOL_FLOAT_SCAN "%lf"
+ #endif
+
+ /* constants
+--- sox-12.17.5/configure.in 2004-08-06 16:08:20.000000000 -0700
++++ sox-12.17.5.new/configure.in 2004-09-30 15:37:54.286963256 -0700
+@@ -273,7 +273,7 @@
+ dnl Generate output files...
+
+ AC_CONFIG_HEADER(stconfig.h)
+-AC_CREATE_STDINT_H(ststdint.h)
++dnl AX_CREATE_STDINT_H(ststdint.h)
+
+ AC_CONFIG_FILES([libst-config Makefile gsm/Makefile])
+ AC_CONFIG_FILES([play], [chmod +x play])
+--- sox-12.17.5/st.h 2004-07-30 19:01:50.000000000 -0700
++++ sox-12.17.5.new/st.h 2004-09-30 15:40:06.405878128 -0700
+@@ -17,7 +17,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include "ststdint.h"
++#include <stdint.h>
+
+ /* Release 12.17.5 of libst */
+ #define ST_LIB_VERSION_CODE 0x0c1105
diff --git a/recipes/sox/sox_12.17.5.bb b/recipes/sox/sox_12.17.5.bb
new file mode 100644
index 0000000000..a3cd84e726
--- /dev/null
+++ b/recipes/sox/sox_12.17.5.bb
@@ -0,0 +1,20 @@
+# sox OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
+It converts audio files among various standard audio file formats \
+and can apply different effects and filters to the audio data."
+LICENSE="GPL"
+HOMEPAGE="http://sox.sourceforge.net"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz; \
+ file://uclibc-fixes.patch;patch=1"
+
+inherit autotools
+
+do_install() {
+ make bindir="${D}${bindir}" libdir="${D}${libdir}" mandir="${D}/${mandir}" includedir="${D}${includedir}" install
+ rm ${D}${bindir}/rec
+ ln -s /usr/bin/play ${D}${bindir}/rec
+}
diff --git a/recipes/sox/sox_13.0.0.bb b/recipes/sox/sox_13.0.0.bb
new file mode 100644
index 0000000000..f5c554799d
--- /dev/null
+++ b/recipes/sox/sox_13.0.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
+It converts audio files among various standard audio file formats \
+and can apply different effects and filters to the audio data."
+HOMEPAGE = "http://sox.sourceforge.net"
+SECTION = "audio"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz \
+ file://src-Makefile.am.patch;patch=1"
+
+inherit autotools
+
+do_install() {
+ make bindir="${D}${bindir}" libdir="${D}${libdir}" mandir="${D}/${mandir}" includedir="${D}${includedir}" install
+ rm ${D}${bindir}/rec
+ ln -s /usr/bin/play ${D}${bindir}/rec
+}