aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sphyrna
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sphyrna
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sphyrna')
-rw-r--r--recipes/sphyrna/sphyrna-python_svn.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/sphyrna/sphyrna-python_svn.bb b/recipes/sphyrna/sphyrna-python_svn.bb
new file mode 100644
index 0000000000..011c496fe4
--- /dev/null
+++ b/recipes/sphyrna/sphyrna-python_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Sphyrna - Hammerhead Reverse Engineering"
+HOMEPAGE = "http://projects.linuxtogo.org/projects/sphyrna"
+LICENSE = "GPLv2"
+DEPENDS = "readline"
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://projects.linuxtogo.org/svn;module=sphyrna"
+
+S = "${WORKDIR}/sphyrna"
+
+inherit autotools
+
+PACKAGES = "${PN}-dbg sphyrna-console sphyrna-python"
+
+FILES_sphyrna-console = "${bindir}/hhconsole"
+FILES_sphyrna-python = "${bindir}/decode.py ${libdir}/python*/site-packages/sphyrna/*"
+
+PACKAGE_ARCH_sphyrna-python = "all"
+RDEPENDS_sphyrna-python = "python-core python-re"