aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools/squashfs-tools_2.0r2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/squashfs-tools/squashfs-tools_2.0r2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/squashfs-tools/squashfs-tools_2.0r2.bb')
-rw-r--r--recipes/squashfs-tools/squashfs-tools_2.0r2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools_2.0r2.bb b/recipes/squashfs-tools/squashfs-tools_2.0r2.bb
new file mode 100644
index 0000000000..25be0837d2
--- /dev/null
+++ b/recipes/squashfs-tools/squashfs-tools_2.0r2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
+DEPENDS = "lzma"
+SECTION = "base"
+LICENSE = "GPLv2"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
+ file://flags.patch;patch=1 \
+ file://squashfs2.0-tools-lzma.patch;patch=1"
+S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
+
+prefix = ""
+
+do_compile() {
+ oe_runmake
+ oe_runmake mksquashfs-lzma
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
+ install -m 0755 mksquashfs-lzma ${D}${sbindir}/
+}