aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-09-26 16:25:50 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-10-07 21:42:21 -0300
commit2b7891e0ffb5be605a87f581c1f58930db9654c7 (patch)
treeb7f3e976f8694b77858ce49294c645efcb34097e /recipes/squashfs-tools
parentdf9d3c175db889fca38947e741bfc8aab946fae7 (diff)
downloadopenembedded-2b7891e0ffb5be605a87f581c1f58930db9654c7.tar.gz
squashfs-tools: refactor 3.3 and 4.0 recipes and use INC_PR
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/squashfs-tools')
-rw-r--r--recipes/squashfs-tools/squashfs-tools-native_3.3.bb2
-rw-r--r--recipes/squashfs-tools/squashfs-tools-native_4.0.bb2
-rw-r--r--recipes/squashfs-tools/squashfs-tools.inc7
-rw-r--r--recipes/squashfs-tools/squashfs-tools_3.3.bb8
-rw-r--r--recipes/squashfs-tools/squashfs-tools_4.0.bb11
5 files changed, 12 insertions, 18 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools-native_3.3.bb b/recipes/squashfs-tools/squashfs-tools-native_3.3.bb
index 5858bb18d6..1a82323951 100644
--- a/recipes/squashfs-tools/squashfs-tools-native_3.3.bb
+++ b/recipes/squashfs-tools/squashfs-tools-native_3.3.bb
@@ -1,5 +1,5 @@
require squashfs-tools_${PV}.bb
-PR = "r0"
+PR = "${INC_PR}.1"
inherit native
diff --git a/recipes/squashfs-tools/squashfs-tools-native_4.0.bb b/recipes/squashfs-tools/squashfs-tools-native_4.0.bb
index 5858bb18d6..1a82323951 100644
--- a/recipes/squashfs-tools/squashfs-tools-native_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools-native_4.0.bb
@@ -1,5 +1,5 @@
require squashfs-tools_${PV}.bb
-PR = "r0"
+PR = "${INC_PR}.1"
inherit native
diff --git a/recipes/squashfs-tools/squashfs-tools.inc b/recipes/squashfs-tools/squashfs-tools.inc
index f27d9ec79a..d06e1e52ec 100644
--- a/recipes/squashfs-tools/squashfs-tools.inc
+++ b/recipes/squashfs-tools/squashfs-tools.inc
@@ -1,11 +1,16 @@
DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
SECTION = "base"
LICENSE = "GPLv2"
-
DEPENDS = "zlib"
+INC_PR = "r1"
S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
+# required to share same place with -lzma specific packages
+FILESPATHPKG = "squashfs-tools-${PV}:squashfs-tools:files"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz"
+
prefix = ""
do_compile() {
diff --git a/recipes/squashfs-tools/squashfs-tools_3.3.bb b/recipes/squashfs-tools/squashfs-tools_3.3.bb
index 2bf0a98ccb..ce6b7ce0f3 100644
--- a/recipes/squashfs-tools/squashfs-tools_3.3.bb
+++ b/recipes/squashfs-tools/squashfs-tools_3.3.bb
@@ -1,8 +1,4 @@
require squashfs-tools.inc
-PR = "r0"
-
-# some release have .tgz, some have .tar.gz, so keep that outside the .inc file
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tgz \
-file://Makefile.patch;patch=1"
+PR = "${INC_PR}.1"
+SRC_URI += " file://Makefile.patch;patch=1"
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
index 8299cd6fdf..0de5794b95 100644
--- a/recipes/squashfs-tools/squashfs-tools_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools_4.0.bb
@@ -1,12 +1,5 @@
require squashfs-tools.inc
-PR = "r0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
-
-# some release have .tgz, some have .tar.gz, so keep that outside the .inc file
-
-#http://ovh.dl.sourceforge.net/sourceforge/squashfs/squashfs4.0.tar.gz
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
-file://Makefile.patch;patch=1"
-
+SRC_URI += " file://Makefile.patch;patch=1"