aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-11-19 16:15:55 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-11-19 17:04:41 -0200
commite0663b38790816d40d8d168d836d2a5c1232e6ea (patch)
treeb5542d1ac26b8801675a905ef0a7b65b585abb1c /recipes/squashfs-tools
parente27dc196988cd827cce7268440f9fe5f9fc51987 (diff)
downloadopenembedded-e0663b38790816d40d8d168d836d2a5c1232e6ea.tar.gz
squashfs-tools: add .inc usage again to avoid duplicated logic
In the effort to avoid duplicated code we've added back the .inc usage otherwise most of code and compilation logic is duplicated between 3.3 and 4.0 recipes. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/squashfs-tools')
-rw-r--r--recipes/squashfs-tools/squashfs-tools.inc2
-rw-r--r--recipes/squashfs-tools/squashfs-tools_4.0.bb33
2 files changed, 7 insertions, 28 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools.inc b/recipes/squashfs-tools/squashfs-tools.inc
index d06e1e52ec..aa75eaa898 100644
--- a/recipes/squashfs-tools/squashfs-tools.inc
+++ b/recipes/squashfs-tools/squashfs-tools.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
SECTION = "base"
LICENSE = "GPLv2"
DEPENDS = "zlib"
-INC_PR = "r1"
+INC_PR = "r2"
S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
index 4e18489e7b..29d82a83b0 100644
--- a/recipes/squashfs-tools/squashfs-tools_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools_4.0.bb
@@ -1,36 +1,15 @@
-DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
-SECTION = "base"
-LICENSE = "GPLv2"
-DEPENDS = "zlib"
-PR = "r2"
+require squashfs-tools.inc
+PR = "${INC_PR}.2"
-# 2009-10-22 snapshot
-#SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/pkl/squashfs4.0-lzma-snapshot.tgz"
-#S = "${WORKDIR}/squashfs4.0-lzma-snapshot/squashfs-tools"
-
-SRC_URI = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE}"
+# This override is required since this has not yet been released
+SRC_URI = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE} \
+ http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
S = "${WORKDIR}/squashfs/squashfs-tools"
-SRC_URI += "http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
-
-COMP_DEFAULT = gzip
-
EXTRA_OEMAKE += "LZMA_SUPPORT=1 LZMA_DIR=../.."
-
TARGET_CC_ARCH += "${LDFLAGS}"
# the COMP_DEFAULT macro should result in a string including quotes: "gzip"
+COMP_DEFAULT = gzip
CFLAGS_append = ' -I. -I../../C -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
-D_GNU_SOURCE -DLZMA_SUPPORT -DCOMP_DEFAULT=\\"${COMP_DEFAULT}\\" '
-
-prefix = ""
-
-do_compile() {
- oe_runmake mksquashfs
-}
-
-do_install () {
- install -d ${D}${sbindir}
- install -m 0755 mksquashfs ${D}${sbindir}/
-}
-