aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/stage-manager
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-15 20:06:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-21 20:28:50 -0700
commitcaa6067f7faf33200681c75843ce2e059cb1c0b4 (patch)
tree334e6f6ab9b6dea945d192cb73afda3b30dd218f /recipes/stage-manager
parente84f4995e257e0505fb73432cbd2a9f53cdf074b (diff)
downloadopenembedded-caa6067f7faf33200681c75843ce2e059cb1c0b4.tar.gz
Various fixes for cp argument portability
Diffstat (limited to 'recipes/stage-manager')
-rwxr-xr-xrecipes/stage-manager/files/stage-manager2
-rwxr-xr-xrecipes/stage-manager/files/stage-manager-ipkg8
-rw-r--r--recipes/stage-manager/stagemanager-native_0.0.1.bb2
3 files changed, 9 insertions, 3 deletions
diff --git a/recipes/stage-manager/files/stage-manager b/recipes/stage-manager/files/stage-manager
index 536d1afda0..0c01a18f94 100755
--- a/recipes/stage-manager/files/stage-manager
+++ b/recipes/stage-manager/files/stage-manager
@@ -91,7 +91,7 @@ if __name__ == "__main__":
if options.copydir:
copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
mkdirhier(os.path.split(copypath)[0])
- os.system("cp -dp " + path + " " + copypath)
+ os.system("cp -Pp " + path + " " + copypath)
def copydir(path, fstamp):
if options.copydir:
diff --git a/recipes/stage-manager/files/stage-manager-ipkg b/recipes/stage-manager/files/stage-manager-ipkg
index 07005e3cb0..53c172e77a 100755
--- a/recipes/stage-manager/files/stage-manager-ipkg
+++ b/recipes/stage-manager/files/stage-manager-ipkg
@@ -109,7 +109,13 @@ Valid destinations are directories or one of the dest names from $IPKG_CONF:" >&
IPKG_DIR_PREFIX=usr/lib/ipkg
IPKG_LISTS_DIR=$IPKG_OFFLINE_ROOT/$IPKG_DIR_PREFIX/lists
IPKG_PENDING_DIR=$IPKG_OFFLINE_ROOT/$IPKG_DIR_PREFIX/pending
- IPKG_TMP=`mktemp -d`
+
+ # test for bsd mktemp and pass -t <prefix> when needed
+ if (mktemp -V) ; then
+ IPKG_TMP=`mktemp -d`
+ else
+ IPKG_TMP=`mktemp -d -t ipkg`
+ fi
if [ ! -d "$IPKG_TMP" ]; then
echo "Error, could not create a temp directory"
diff --git a/recipes/stage-manager/stagemanager-native_0.0.1.bb b/recipes/stage-manager/stagemanager-native_0.0.1.bb
index 9eeac4b073..b54c38df02 100644
--- a/recipes/stage-manager/stagemanager-native_0.0.1.bb
+++ b/recipes/stage-manager/stagemanager-native_0.0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r13"
+PR = "r14"
SRC_URI = "file://stage-manager \
file://stage-manager-ipkg \