aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/stopwatch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-20 12:55:45 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-20 13:09:26 +0100
commitc0002bd2f71a05d8bb125ba40f1c489a29436a9e (patch)
tree2035414a0ac935a771f187f8ab35e5217766fe39 /recipes/stopwatch
parent4750e2e563904042a2375100213f0f5cfadde176 (diff)
downloadopenembedded-c0002bd2f71a05d8bb125ba40f1c489a29436a9e.tar.gz
stopwatch: new recipe for QT4 based stopwatch
* Author: Christof Musik * can be used as stop watch * has countdown capability (e.g. for next holiday) * survives suspend/resume Signed-off-by: Christian Rüb <christian.rueb@gmx.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/stopwatch')
-rw-r--r--recipes/stopwatch/stopwatch_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/stopwatch/stopwatch_git.bb b/recipes/stopwatch/stopwatch_git.bb
new file mode 100644
index 0000000000..f0d40da54b
--- /dev/null
+++ b/recipes/stopwatch/stopwatch_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Simple Qt based stop watch"
+AUTHOR = "Christof Musik"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+HOMEPAGE = "http://git.senfdax.de"
+LICENSE = "GPL QPL"
+DEPENDS = "qt4-x11-free"
+PV = "1.3.1+gitr${SRCREV}"
+PR = "r0"
+
+inherit qt4x11
+
+SRC_URI = "git://git.senfdax.de/git/stopwatch;protocol=http;tag=master;branch=master"
+S = "${WORKDIR}/git/"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}stopwatch ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install ${S}desktop/stopwatch.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install ${S}desktop/stopwatch.png ${D}${datadir}/pixmaps/
+ install -d ${D}${datadir}/${PN}
+ install ${S}desktop/om.style ${D}${datadir}/${PN}/
+}