aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/strace
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-29 13:34:52 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-29 21:06:00 -0700
commitc02c3122f6955f20669f9a0e96cfd13f024a2761 (patch)
tree7c8f80fac202f6190ff94ea1b786f87219b32fd5 /recipes/strace
parent62a3c30d2f843e76256345abb59da23abdf9af4a (diff)
downloadopenembedded-c02c3122f6955f20669f9a0e96cfd13f024a2761.tar.gz
strace: Fix compilation for 4.5.14 and 4.5.18
* Delete drop-ctl-proc.patch its included in mips-sigcontext.patch. * Delete strace-dont-include-linux-dirent-h.patch as it is not needed for 4.5.18. * Combine the SRC_URIs for mips and non mips in 4.5.14. * Make 4.5.18 default for mips and mipsel. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/strace')
-rw-r--r--recipes/strace/strace-4.5.14/drop-ctl-proc.patch12
-rw-r--r--recipes/strace/strace-4.5.18/strace-dont-include-linux-dirent-h.patch23
-rw-r--r--recipes/strace/strace_4.5.14.bb22
-rw-r--r--recipes/strace/strace_4.5.18.bb5
4 files changed, 6 insertions, 56 deletions
diff --git a/recipes/strace/strace-4.5.14/drop-ctl-proc.patch b/recipes/strace/strace-4.5.14/drop-ctl-proc.patch
deleted file mode 100644
index 468913774a..0000000000
--- a/recipes/strace/strace-4.5.14/drop-ctl-proc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: strace-4.5.14/system.c
-===================================================================
---- strace-4.5.14.orig/system.c 2006-10-01 13:02:08.000000000 +0200
-+++ strace-4.5.14/system.c 2006-10-01 13:02:27.000000000 +0200
-@@ -1578,7 +1578,6 @@
- { CTL_KERN, "CTL_KERN" },
- { CTL_VM, "CTL_VM" },
- { CTL_NET, "CTL_NET" },
-- { CTL_PROC, "CTL_PROC" },
- { CTL_FS, "CTL_FS" },
- { CTL_DEBUG, "CTL_DEBUG" },
- { CTL_DEV, "CTL_DEV" },
diff --git a/recipes/strace/strace-4.5.18/strace-dont-include-linux-dirent-h.patch b/recipes/strace/strace-4.5.18/strace-dont-include-linux-dirent-h.patch
deleted file mode 100644
index 1d50251417..0000000000
--- a/recipes/strace/strace-4.5.18/strace-dont-include-linux-dirent-h.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: strace-4.5.14/file.c
-===================================================================
---- strace-4.5.14.orig/file.c 2009-03-24 08:35:13.000000000 -0700
-+++ strace-4.5.14/file.c 2009-03-24 08:39:43.000000000 -0700
-@@ -35,12 +35,12 @@
-
- #include <dirent.h>
- #ifdef LINUX
--#define dirent kernel_dirent
--#define dirent64 kernel_dirent64
--#include <linux/types.h>
--#include <linux/dirent.h>
--#undef dirent
--#undef dirent64
-+struct kernel_dirent {
-+ unsigned long d_ino;
-+ unsigned long d_off;
-+ unsigned short d_reclen;
-+ char d_name[1];
-+};
- #else
- #define kernel_dirent dirent
- #endif
diff --git a/recipes/strace/strace_4.5.14.bb b/recipes/strace/strace_4.5.14.bb
index d14891727b..88bf8c7f46 100644
--- a/recipes/strace/strace_4.5.14.bb
+++ b/recipes/strace/strace_4.5.14.bb
@@ -1,18 +1,18 @@
DESCRIPTION = "strace is a system call tracing tool."
SECTION = "console/utils"
LICENSE = "GPL"
-PR = "r8"
+PR = "r9"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://glibc-2.5.patch;patch=1 \
file://arm-eabi.patch;patch=1 \
- file://drop-ctl-proc.patch;patch=1 \
file://sh-arch-update.patch;patch=1 \
file://sh-syscall-update.patch;patch=1 \
file://strace-fix-arm-bad-syscall.patch;patch=1 \
file://strace-undef-syscall.patch;patch=1 \
file://strace-arm-no-cachectl.patch;patch=1 \
file://strace-dont-include-linux-dirent-h.patch;patch=1 \
+ file://mips-sigcontext.patch;patch=1 \
"
# The strace-4.5.14-avr32.patch conflicts with some other patches.
@@ -20,27 +20,11 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
# not use them when building for the AVR32.
# The avr32 patch also includes the drop-ctl-proc.patch
# The AVR32 patches are from http://avr32linux.org/twiki/bin/view/Main/STrace
-SRC_URI_avr32 = \
- "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+SRC_URI_avr32 = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://strace-4.5.14-avr32.patch;patch=1 \
file://strace-4.5.14-avr32-add-syscalls-up-to-sysvipc.patch;patch=1 \
"
-# Again, a different set of patches for MIPS. See http://bugs.openembedded.net/show_bug.cgi?id=2221
-MIPS = "\
- ${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
- file://glibc-2.5.patch;patch=1 \
- file://arm-eabi.patch;patch=1 \
- file://sh-arch-update.patch;patch=1 \
- file://sh-syscall-update.patch;patch=1 \
- file://strace-fix-arm-bad-syscall.patch;patch=1 \
- file://strace-undef-syscall.patch;patch=1 \
- file://strace-arm-no-cachectl.patch;patch=1 \
- file://mips-sigcontext.patch;patch=1 \
-"
-SRC_URI_mips = "${MIPS}"
-SRC_URI_mipsel = "${MIPS}"
-
inherit autotools
export INCLUDES = "-I. -I./linux"
diff --git a/recipes/strace/strace_4.5.18.bb b/recipes/strace/strace_4.5.18.bb
index 049706c6ff..a80758f1d4 100644
--- a/recipes/strace/strace_4.5.18.bb
+++ b/recipes/strace/strace_4.5.18.bb
@@ -1,14 +1,15 @@
DESCRIPTION = "strace is a system call tracing tool."
SECTION = "console/utils"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
# this recipe is missing patches for arm and sh
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_avr32 = "1"
+DEFAULT_PREFERENCE_mips = "1"
+DEFAULT_PREFERENCE_mipsel = "1"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
- file://strace-dont-include-linux-dirent-h.patch;patch=1 \
"
SRC_URI_avr32 = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \