aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/subapplet
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/subapplet
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/subapplet')
-rw-r--r--recipes/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch11
-rw-r--r--recipes/subapplet/subapplet_1.0.8.bb39
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch b/recipes/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch
new file mode 100644
index 0000000000..fede3c7cf9
--- /dev/null
+++ b/recipes/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch
@@ -0,0 +1,11 @@
+--- SubApplet-1.0.8/subapplet.cpp.orig 2004-05-04 00:26:22 +0200
++++ SubApplet-1.0.8/subapplet.cpp 2004-12-22 10:11:52 +0100
+@@ -115,6 +115,8 @@
+ setToggleType(QButton::Toggle);
+ setOnIconSet(QIconSet(mPixmapOpen, QIconSet::Small));
+ setOffIconSet(QIconSet(mPixmapClosed, QIconSet::Small));
++ setFixedWidth(mPixmapOpen.width());
++ setFixedHeight(mPixmapOpen.height());
+ setOn(false);
+ setDown(false);
+ setAutoRaise(mUseFlatButton);
diff --git a/recipes/subapplet/subapplet_1.0.8.bb b/recipes/subapplet/subapplet_1.0.8.bb
new file mode 100644
index 0000000000..0ebc6c3b13
--- /dev/null
+++ b/recipes/subapplet/subapplet_1.0.8.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Applet for the Qtopia environment taskbar that provides an extension panel \
+for the taskbar that let's you load lot's of applet's without taking up space \
+in the normal taskbar."
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://sourceforge.net/projects/subapplet/"
+PR = "r7"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/subapplet/subapplet-1.0.8.tar.gz \
+ file://toolbar-resize-fix.patch;patch=1"
+
+S = "${WORKDIR}/SubApplet-1.0.8"
+
+inherit palmtop
+
+QMAKE_PROFILES = "subapplet.pro"
+
+do_install() {
+ install -d ${D}${palmtopdir}/plugins/applets ${D}${palmtopdir}/pics/subapplet/
+ install -m 0644 *.png ${D}${palmtopdir}/pics/subapplet/
+ oe_libinstall -so -C rel/opt/QtPalmtop/plugins/applets libsubapplet ${D}${palmtopdir}/plugins/applets/
+}
+
+pkg_postinst() {
+#!/bin/sh
+if pidof -s qpe >/dev/null; then
+ /usr/bin/qcop QPE/TaskBar "reloadApplets()"
+else
+ exit 0
+fi
+ if [ -n "$D" ]; then false; fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+/usr/bin/qcop QPE/TaskBar "reloadApplets()"
+ if [ -n "$D" ]; then false; fi
+}