aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/subversion/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/subversion/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/subversion/files')
-rw-r--r--recipes/subversion/files/apr-regex.patch19
-rw-r--r--recipes/subversion/files/disable-revision-install.patch22
-rw-r--r--recipes/subversion/files/neon-detection.patch36
3 files changed, 77 insertions, 0 deletions
diff --git a/recipes/subversion/files/apr-regex.patch b/recipes/subversion/files/apr-regex.patch
new file mode 100644
index 0000000000..4f1f50a7d5
--- /dev/null
+++ b/recipes/subversion/files/apr-regex.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- subversion-1.3.1/configure~apr-regex
++++ subversion-1.3.1/configure
+@@ -2933,9 +2933,9 @@
+
+
+
+-APR_VER_REGEX="0\.9\.[5-9]"
++APR_VER_REGEX="0\.9\.12"
+ APR_VER_REGEX_TOO="1\."
+-APU_VER_REGEX="0\.9\.[5-9]"
++APU_VER_REGEX="0\.9\.12"
+ APU_VER_REGEX_TOO="1\."
+
+
diff --git a/recipes/subversion/files/disable-revision-install.patch b/recipes/subversion/files/disable-revision-install.patch
new file mode 100644
index 0000000000..a1c60654cb
--- /dev/null
+++ b/recipes/subversion/files/disable-revision-install.patch
@@ -0,0 +1,22 @@
+--- subversion-1.2.0-r0/Makefile.in.old 2005-07-17 22:28:21.898728312 +0200
++++ subversion-1.2.0-r0/Makefile.in 2005-07-17 22:30:05.361999504 +0200
+@@ -260,7 +260,7 @@
+ clean: external-clean local-clean
+ distclean: external-distclean local-distclean
+ extraclean: external-extraclean local-extraclean
+-install: external-install local-install revision-install
++install: external-install local-install #revision-install
+
+ @INCLUDE_OUTPUTS@
+
+@@ -320,8 +320,8 @@
+ local-install: @INSTALL_RULES@
+
+ ### HACK!! Find a better way to do this
+-revision-install:
+- subversion/svnversion/svnversion $(top_srcdir) /repos/svn/trunk > $(DESTDIR)$(includedir)/subversion-1/svn-revision.txt
++#revision-install:
++# subversion/svnversion/svnversion $(top_srcdir) /repos/svn/trunk > $(DESTDIR)$(includedir)/subversion-1/svn-revision.txt
+
+ install-static: @INSTALL_STATIC_RULES@
+
diff --git a/recipes/subversion/files/neon-detection.patch b/recipes/subversion/files/neon-detection.patch
new file mode 100644
index 0000000000..b567d5c050
--- /dev/null
+++ b/recipes/subversion/files/neon-detection.patch
@@ -0,0 +1,36 @@
+diff --git a/build/ac-macros/neon.m4 b/build/ac-macros/neon.m4
+index 9fcf859..8d964f3 100644
+--- a/build/ac-macros/neon.m4
++++ b/build/ac-macros/neon.m4
+@@ -38,7 +38,7 @@ AC_DEFUN(SVN_LIB_NEON,
+ if test "$withval" = "yes" ; then
+ AC_MSG_ERROR([--with-neon requires an argument.])
+ else
+- neon_config="$withval/bin/neon-config"
++ neon_config="env env PKG_CONFIG_PATH=${withval}:${PKG_CONFIG_PATH} pkg-config neon"
+ fi
+
+ SVN_NEON_CONFIG()
+@@ -117,10 +117,10 @@ dnl SVN_NEON_CONFIG()
+ dnl neon-config found, gather relevant information from it
+ AC_DEFUN(SVN_NEON_CONFIG,
+ [
+- if test -f "$neon_config"; then
+- if test "$neon_config" != ""; then
++ if true; then
++ if true; then
+ AC_MSG_CHECKING([neon library version])
+- NEON_VERSION=`$neon_config --version | sed -e 's/^neon //'`
++ NEON_VERSION=`$neon_config --modversion | sed -e 's/^neon //'`
+ AC_MSG_RESULT([$NEON_VERSION])
+
+ if test -n "`echo \"$NEON_VERSION\" | grep '^0\.25\.'`" ; then
+@@ -133,7 +133,7 @@ AC_DEFUN(SVN_NEON_CONFIG,
+ test "$svn_allowed_neon" = "any"; then
+ svn_allowed_neon_on_system="yes"
+ SVN_NEON_INCLUDES=[`$neon_config --cflags | sed -e 's/-D[^ ]*//g'`]
+- NEON_LIBS=`$neon_config --la-file`
++ NEON_LIBS=`$neon_config --libs`
+ CFLAGS=["$CFLAGS `$neon_config --cflags | sed -e 's/-I[^ ]*//g'`"]
+ svn_lib_neon="yes"
+ break