summaryrefslogtreecommitdiffstats
path: root/recipes/subversion/subversion_1.6.5.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-08-24 21:13:14 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-08-24 21:13:14 +0000
commitc62f14e1aa31dd1b6d67e298108486163b61de59 (patch)
tree27451e9fa7b21ff2d661dbbc640abec6f31b37c0 /recipes/subversion/subversion_1.6.5.bb
parente0041be7a72a025f0f292990161fc2158c1981e6 (diff)
downloadopenembedded-c62f14e1aa31dd1b6d67e298108486163b61de59.tar.gz
subversion: Updated to version 1.6.5. Deleted old unused versions.
Diffstat (limited to 'recipes/subversion/subversion_1.6.5.bb')
-rw-r--r--recipes/subversion/subversion_1.6.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/subversion/subversion_1.6.5.bb b/recipes/subversion/subversion_1.6.5.bb
new file mode 100644
index 0000000000..50f5e6e5d6
--- /dev/null
+++ b/recipes/subversion/subversion_1.6.5.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org/"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1"
+
+EXTRA_OECONF = "--without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+acpaths = "-I build/ac-macros"
+
+# FIXME: Ugly hack!
+do_configure_append() {
+ if ! test -f libtool ; then cp -a *-libtool libtool ; fi
+}
+
+do_stage() {
+ autotools_stage_all
+}