aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/supertux
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-26 16:42:06 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-26 16:43:08 -0700
commita578c12219dd4b29264ae8f914cb6d2e72d7102b (patch)
tree5e7239db0d6420556def31f6d432ed6b7f19cd21 /recipes/supertux
parent97222a4ffc9543e4c687755614512e43d439983f (diff)
downloadopenembedded-a578c12219dd4b29264ae8f914cb6d2e72d7102b.tar.gz
supertux_0.1.3: Fix complilation with gcc 4.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/supertux')
-rw-r--r--recipes/supertux/files/compilation-fixes.patch85
-rw-r--r--recipes/supertux/supertux_0.1.3.bb3
2 files changed, 87 insertions, 1 deletions
diff --git a/recipes/supertux/files/compilation-fixes.patch b/recipes/supertux/files/compilation-fixes.patch
new file mode 100644
index 0000000000..495c735a6c
--- /dev/null
+++ b/recipes/supertux/files/compilation-fixes.patch
@@ -0,0 +1,85 @@
+Index: supertux-0.1.3/src/badguy.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/badguy.cpp
++++ supertux-0.1.3/src/badguy.cpp
+@@ -21,6 +21,7 @@
+ // 02111-1307, USA.
+
+ #include <iostream>
++#include <cstdlib>
+ #include <math.h>
+
+ #include "globals.h"
+Index: supertux-0.1.3/src/configfile.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/configfile.cpp
++++ supertux-0.1.3/src/configfile.cpp
+@@ -18,7 +18,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+ #include <stdlib.h>
+-#include <string>
++#include <cstring>
+ #include "configfile.h"
+ #include "setup.h"
+ #include "globals.h"
+Index: supertux-0.1.3/src/gameobjs.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/gameobjs.cpp
++++ supertux-0.1.3/src/gameobjs.cpp
+@@ -19,6 +19,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ // 02111-1307, USA.
+ #include <algorithm>
++#include <cstring>
+ #include "world.h"
+ #include "tile.h"
+ #include "gameloop.h"
+Index: supertux-0.1.3/src/particlesystem.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/particlesystem.cpp
++++ supertux-0.1.3/src/particlesystem.cpp
+@@ -20,6 +20,7 @@
+ #include "particlesystem.h"
+
+ #include <iostream>
++#include <cstdlib>
+ #include <math.h>
+ #include "globals.h"
+ #include "world.h"
+Index: supertux-0.1.3/src/sprite_manager.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/sprite_manager.cpp
++++ supertux-0.1.3/src/sprite_manager.cpp
+@@ -18,6 +18,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+ #include <iostream>
++#include <cstring>
+ #include "lispreader.h"
+ #include "sprite_manager.h"
+
+Index: supertux-0.1.3/src/tile.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/tile.cpp
++++ supertux-0.1.3/src/tile.cpp
+@@ -21,6 +21,7 @@
+ #include "tile.h"
+ #include "scene.h"
+ #include "assert.h"
++#include <cstring>
+
+ TileManager* TileManager::instance_ = 0;
+ std::set<TileGroup>* TileManager::tilegroups_ = 0;
+Index: supertux-0.1.3/src/worldmap.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/worldmap.cpp
++++ supertux-0.1.3/src/worldmap.cpp
+@@ -20,6 +20,7 @@
+ #include <iostream>
+ #include <fstream>
+ #include <vector>
++#include <cstring>
+ #include <assert.h>
+ #include <unistd.h>
+ #include "globals.h"
diff --git a/recipes/supertux/supertux_0.1.3.bb b/recipes/supertux/supertux_0.1.3.bb
index 41c907c349..b4b81e916b 100644
--- a/recipes/supertux/supertux_0.1.3.bb
+++ b/recipes/supertux/supertux_0.1.3.bb
@@ -3,7 +3,7 @@ in a style similar to the original SuperMario games."
SECTION = "games"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
RDEPENDS_${PN} += "libmikmod"
@@ -14,6 +14,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/super-tux/supertux-${PV}.tar.bz2 \
# http://ssel.vub.ac.be/Members/DennisWagelaar/download/zaurus/supertux-0.1.2-fp.patch.gz \
file://supertux.png \
file://install-no-overwrite.patch \
+ file://compilation-fixes.patch \
file://supertux.desktop \
"