aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/swfdec/swfdec-mozilla_0.9.2.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-08-19 20:52:28 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-08-19 20:52:28 +0000
commitada6f217e946c731fbc42d831021aa1fcae28777 (patch)
tree1099a2aa2f1803c90e42ed62ac2ad69c20b5027c /recipes/swfdec/swfdec-mozilla_0.9.2.bb
parente28e9d0b52f26b078b5be4e5ea61e97852ccffac (diff)
downloadopenembedded-ada6f217e946c731fbc42d831021aa1fcae28777.tar.gz
swfdec: Fixed dependencies and package splitting. Disabled static. Packaged stable 0.8.2.
Diffstat (limited to 'recipes/swfdec/swfdec-mozilla_0.9.2.bb')
-rw-r--r--recipes/swfdec/swfdec-mozilla_0.9.2.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/recipes/swfdec/swfdec-mozilla_0.9.2.bb b/recipes/swfdec/swfdec-mozilla_0.9.2.bb
index 74f4e7b942..4bb8c607af 100644
--- a/recipes/swfdec/swfdec-mozilla_0.9.2.bb
+++ b/recipes/swfdec/swfdec-mozilla_0.9.2.bb
@@ -1,20 +1,23 @@
DESCRIPTION = "Swfdec plugin for browsers using NPAPI. Swfdec is a decoder/renderer for Macromedia Flash animations."
LICENSE = "LGPL"
-
-DEPENDS = "gst-ffmpeg swfdec gstreamer libsoup-2.4 pango cairo liboil zlib gtk+ alsa-lib \
- ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+PR = "r1"
+DEPENDS = "swfdec glib-2.0"
RDEPENDS = "gst-ffmpeg"
SRC_URI = "http://swfdec.freedesktop.org/download/swfdec-mozilla/0.9/${P}.tar.gz \
"
-inherit autotools pkgconfig
+inherit autotools pkgconfig gtk-icon-cache
+
+EXTRA_OECONF = "--disable-static"
+
+do_install_append() {
+ rm ${D}${libdir}/mozilla/plugins/*.la
+}
do_stage() {
autotools_stage_all
}
-FILES_${PN} += "${datadir}/icons ${libdir}/mozilla/plugins/*.so"
-FILES_${PN}-dev += "${libdir}/mozilla/plugins/*a"
+FILES_${PN} += "${libdir}/mozilla/plugins/*.so"
FILES_${PN}-dbg += "${libdir}/mozilla/plugins/.debug"
-